Cannot add my music files to ROCK

Roon rock latest version

Before installing Roon rock on a dedicated Intel nuc I had roon server installed on my windows computor. My music is installed on 6 external drives on the same computor and I had no problems importing the music. Now Rock doesnt find the folders! I have tried the different tips I have found here but it does not help! Can anyone help me?

Hi @Per_Svensson,

There are a couple of ways to store music and access it Roon. You can either have an internal drive, a USB connected drive, or a network share. It looks like before you were using the external USB drives connected to the Windows machine.

If you are leaving the drives connected to the Windows machine you’ll have to access the media over the network. To do this, you’ll want to take a look at these articles:

  1. Sharing a folder over the network from Windows
  2. Adding a network share in Roon

Alternatively, you can connect the drives via USB and they should show up when you go to Settings > Storage.

Let me know if you have any questions!

Thank you Dylan! I tried both articles but nothing works! What do you mean by connecting the drives via USB? They are WDC ata discs mounted in the Windows computor!

Hi @Per_Svensson,

Can you share screenshots of what you’re entering into Roon as well as the share settings for the path in Windows?

![docx|666x500] (upload://nUZb3hgqLWWrCBe11hVYDCjJs5B.png)

The Roon Core running on your ROCK/NUC needs to know the username (Användarnamm) and password (Lösenord) for the Windows network share that you have defined (\\server\I). You haven’t filled in these fields, so Windows won’t let Roon connect to this share.

1 Like

I have tried with administrator and left the passwoed open as I dont have one with the same result!

I added a password and now it works?!? This was not nessecary with roonserver on the windows computor! I now want to restore from a backup done on the computor! I suppose I will then run into a problem with the adress! How do I handle that?

I managed to restore the backup and change the filenames so now all music is found!
But I lost audio, no audio units are found?!? What happened? How do I restore?

Hi @Per_Svensson,

Can you share a screenshot of Settings > Audio?

Any change after rebooting?

Hello Dylan!
I srarted a new thread on this problem, Rock has last all audio devices, and there I wrote that the NUC rebooted on its own and then the audio devices were back! So everything is fine now and it is really rocking! Thanks for all support!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.