Cannot add network folder from windows 10 to ROCK

Roon Rock running on NUC8i7


Cat 6 gigabit Ethernet connecting intel NUC and Windows 10 PC where music library is stored


I have shared a folder full of FLAC files that I keep on SSD in my Windows 10 PC. I have shared the folder, granted read/wright permissions to “everyone.” When attempting to add folder in Roon I get an “unexpected error.”

I have verified that I can access the folder from another PC (macbork pro) on my network.

I don’t have any spaces in my filepath, which is FLAC \Officepc\flac.

I do have a single special character in my password and my username is my gmail account I have with Microsoft. I am unwilling to change my password to drop the special character.


do you have SMB V1 enabled in your windows machine? Also turn off firewalls while you troubleshoot.

I’m unsure what SMB V1 is as far as a setting goes.

I can use a mac to access the network shared folder w/o issue and tha typically uses SMB. I have all of ubiquiti Unifi firewalls defaulted to basic with all threat management defaulted

what path are you using to add a network share in Roon Settings storage? screen shot is good

Hi @Jeremy_Hutchins,

Starting out, I definitely recommend checking out this article for some great tips on adding network shares in Roon:’m_having_trouble_setting_up_Roon_with_my_NAS

Can you share a screenshot of what you’re entering into Roon as well as the error message you’re seeing?

Thank you for the link. I used that as well.

I tried multiple different variations of the add network folder, so one screen shot wont help.

I go to settings, storage, add folder then add netowork share.

For network share location I started with “\Officepc\flac” which I copied from the network path on windows 10 when going under properties and sharing tab. I have also tried with smb://officepc/flac.

Username I have left blank and I’ve also placed in windows 10/microsoft account [Email removed by support]
Password ~
Workgroup I’ve tried with this blank and with the word workgroup

My error is in a pink box below workgroup field and it says “There was an unexpected error: UnexpectedError”

Does windows assign a different username other than email account for windows 10?

Hi @Jeremy_Hutchins,

As Wizardofoz mentioned above, you’ll want to make sure that SMB V1 is enabled, which is no longer enabled by default on Windows. You can read more about that here:

Your username is typically the name associated with your Windows user login, not a Microsoft account email address. Do you know what the Windows User name is for the user profile you used to set up the share?

Still no luck.

I’ve enabled SMB V1 and my error has changed. I’m currently replacing some PC parts and will update with new status sometime this week once I get PC, which houses FLAC library, back up and running.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.