Cannot Airplay to Apple TV 4K

Core Machine (Operating system/System info/Roon build number)

Apple iMac 27" Late 2013 8GB RAM 1TB Fusion Drive MacOS 10.14.4

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Zen Internet Fibre internet connection, Netgear D6300 Modem/Router connected (via powerline ethernet) to Apple TV 4K at the other end of the house (very thick stone walls, wi-fi cannot reach there).

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Apple TV 4K with latest TV OS (12.3)

Description Of Issue

I am trying to Airplay from the Mac to my Apple TV. On the iMac, I get prompted for a password for the Apple TV 4K (even though that requirement is not enabled on the Airplay settings on the Apple TV). Having read on the forums that some people had been successful in making the Apple TV Airplay connection by enabling the passcode requirement on the Apple TV for Airplay, I tried that. However, that did not work either. It just refuses to make the connection.

I can send music from iTunes to the Apple TV via Airplay, but not from the Roon app.

Where can I go from here to get this working?

Thanks in advance,


Hello @MortalWombatUK,

Thanks for your post here. Often times we have seen special settings that need to be applied to Netgear routers, specifically disabling the “Enable Smart Connect” option in settings. Can you please check to see if you have this option on your Netgear router and let me know if that changes anything?

Also, I would start with temporarily eliminating the powerline adapters from the equation to see if that has any change as Powerline adapters have been known to cause issues in the past. If you temporarily connect your Apple TV to the router via Ethernet, do you still experience the same issue?


1 Like

Hi Noris,

My router does not have that setting, (it is a fairly old router).

I have attached the Apple TV directly to the router with ethernet cable, but Roon still fails to see it. However, if I remove the ethernet cable from the Apple TV and allow the Apple TV to establish a wireless connection to the router, then I am able to configure Roon to see, and play music to the Apple TV via Airplay.

The successful setup via wifi was only possible because the Apple TV flashed up a large 4 digit passcode across the TV screen which I subsequently typed into the Roon prompt for a passcode. Whenever I connect via ethernet/powerline, I get no such prompt on the Apple TV and resort to entering the 6 digit generated code that appears within the Apple TV settings-Airplay-Allow Access screen. Roon never really seems to accept any of these 6 digit passcode (just shows an animated “enabling” icon which will disappear when I click elsewhere on the iMac screen).

Reading my response so far, you might be thinking that I have dodgy ethernet ports on the router or the Apple TV. However, the ethernet ports are behaving fine (the Apple TV receives an IP address and connects just fine to the home network, both via ethernet and wifi).

Unfortunately, the TV (and the Apple TV) will need to go back to the other end of the house where the wifi signal simply cannot reach (hence the Powerline solution).

I am considering getting a mesh wifi system hoping that will provide a single wifi network throughout the house.

Is there anything else I can try?



Hi @MortalWombatUK,

Thanks fro letting me know that info. I spoke to the team today regarding this issue, they have suggested changing the Apple TV’s settings to as follows:

Can you give this a try and let me know how it goes?

Hi Noris,

Thanks for the info. I have changed the settings and this seems to have fixed the issue. My core (iMac) must be connected to the router via ethernet it seems. Strangely, iTunes itself now cannot connect to the Apple TV via Airplay, but I am not too fussed about that for the time being. I am now in a position to give Roon a trial with my current setup.

Thanks for your help with this!


Hi @MortalWombatUK,

Thanks for letting me know that those settings worked for you! I am not sure why iTunes is not connecting now, maybe there is a new version of iTunes available that would help with this aspect?

Either way, glad these settings have sorted you out to properly trial Roon :+1:.
If you have any other issues, don’t hesitate to reach out!

– Noris

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.