Cannot backup Roon to attached Time Machine WD Passport [Resolved]


Apologies if this has been covered, but I couldn’t find it in the Knowledge Base

I am new to Roon, running the latest version with my 2017 iMac as a Core (macOS Mojave v 10.14.3), iPad Pro as Controller, and Bluesound Node 2i endpoint connected to my Rega DAC-R and HiFi system.

Everything works really well, but I can’t seem to be able to set up a backup

I have a 2TB WD Passport attached to the iMac via Thunderbolt / USB-C, which is set as my Time Machine for system/file backups. The iMac has a 1TB hard drive with 750GB utilised, so there is over 1TB of freespace on the Time Machine, so I want to also use it as the destination drive for my Roon back ups. In essence, one 2TB back-up drive for everything.

I point Roon at the Time Machine drive to schedule the backup, and consistently get an error message “Failed to get authorisation to access your account” - see attached screengrabs. What “account” is it failing to get access to? My Roon account? My iMac user ID? The error message is too vague to work out what the issue is, so any help or guidance would be much appreciated

Cheers, Matt

A search for backup in the knowledge base reveals:
User Guide > Getting Started > Backups


Using Other Backup Applications

Because the Roon database is frequently being updated in the background with new metadata, cover art, artist information, and more, backing up your “live” Roon database using external programs can result in corrupt backups.

We strongly recommend against using Time Machine, Crashplan, Backblaze, or other backup applications to backup your “live” Roon database.

If you would like to use any of these applications to back up Roon, set up a Scheduled Backup and tell your backup program to backup the RoonBackups folder.


Yes, saw that. But I’m not trying to use the Time Machine application to back-up Roon, I’m trying to use an external drive that is named Time Machine and is being used by Time Machine as a backup destination as my backup destination for Roon. I’m happy to use the Roon back-up application, but want to point it at a drive that is also being utilised by Time Machine. And in doing so I get this error message.

Where is your core? Is it on the same iMac or on another computer? If it’s on another computer then you need to map to the iMac drive share via network. The core is controlled by any computer but the drive locations are with respect to the core not the control application.

Roon core is on the iMac, and the WD Passport drive (named Time Machine and used by Time Machine) is connected to the same iMac’s Thunderbolt port. So there’s no networking involved, it should be a direct connection.

Maybe that’s why you can’t access it? I don’t know.

Instruct Roon to backup to a local folder of your iMac. Tell the Time Machine Application to backup the RoonBackups folder that got created in the folder you instructed Roon to save the backup.

Ok maybe your iMac needs to have permissions set to write the top level (root) of the drive. Try creating a folder in finder on the WD drive to use for the backups. Also as noted you can backup to a local folder on your iMac too as to be sure you have 2 backup locations.

That did it! I created a new folder named ‘Roon’ in the WD Passport Time Machine. Pointed Roon at that new folder and it worked. As you said, it seems that Roon didn’t have permissions to create the folder structure it needed, but if I created one on the drive (as an Administrator) it then had what it needed.

Thanks for your guidance - do I need to do anything to close this out, eg is there a way of marking the thread as ‘Solved!’ to help future users?

Cheers, Matt

Someone will close it no doubt but I’ll mark as resolved. (Done)

It’s not roon that didn’t have permissions it’s your Mac user. Typically writing files to root level locations requires admin authentication. Creating a folder is allowed however within finder but you might have been prompted for authentication by finder.

@Carl thanks mate

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.