Cannot connect my Windows 10 Roonserver to my QNAP NAS [Resolved]

After resetting my QNAP NAS (TS 451+), I have lost the storage connection between my Windows 10 RoonServer and the QNAP NAS on which the music files (AIFF) are stored.
I have followed the recommendation to resolve the issue posted on this Roon Community blog but nothing seems to work that would allow me reestablishing the connection.
I can see the NAS storage on my network in Explorer on my Windows 10 PC and can connect using a web connection but I cannot connect the storage in Roon; it says that the drive/s are unavailable.

Any advice what I should do?

Many thanks in advance


My Winfows 10 PC is Small Green Computer i7
It is connected through ethernet cabling and Netgear ProSafe GS108 switches.
RoonCore version is 1.5 (build 334) stable 64 bit

cannot access.JPG
Capture QNAP Device Details.JPG
Connection QNAP.JPG
Screen network.JPG

Hey @Jan_Werkman — Thanks for reaching out to us. We appreciate the report!

Since noticing this behavior have you tried rebooting the QNAP, your Core machine, and networking hardware?

Can you share a screenshot of what you are adding in Roon for the QNAP watched folder? Are you including the correct username and password here?

Looking at your most recent screenshots it looks like you’re not able to connect in File Explorer either. If you use the IP address instead are you able to connect?


I bet when he reset the NAS the IP address changed from what was previously stored in Roon. This is not uncommon. I have started setting the IP address to static on my devices so as to not have this happen accidentally.

1 Like

The IP address of my NAS is static and thus rermained unchanged.


I’d suggest checking SMB versions. Microsoft recently disabled SMB1 in Windows 10 outright. If QNAP is using an older Samba version and/or bad config, this would prevent Windows from connecting. (On Synology units, they have settings for the minimum and maximum SMB versions supported. Maybe QNAP has something similar?)

1 Like

This isn’t related to having SMB1 enabled in Windows is it?

@cwichura snap! Posts crossed.

To enable it in Windows 10 do the following

Go to Control Panel > Programs and Features > Turn Windows Features on or off > check the box for “SMB 1.0/CIFS File Sharing Support”

1 Like

SMB1 is enabled in Windows. The NAS hat SMB3 as highest version enabled.

And the despite that the problem remains.

The problem has been resolved.

The RoonServer could not connect to the music files on the NAS because the password to the NAS was changed. Without disabling the existing path that incuded the old password, a new path, which incuded the new password was not accepted.
Hence, after disabling or removing the old path the new path to the NAS drive could be installed.

Had you changed the password?

Next time (I hope there isn’t one ;-)), try editing the connection instead of disabling the old one and creating a new one.

I had thought of that but did not find the place where to replace the password.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.