Cannot connect remotely [Solved]

I have Roon installed on a Windows PC with “Accept connections from remotes” on YES. It has a static IP:; firewall is off.
Roon Remote is installed on my Android 5,1 tablet. If I try to connect to a Roon Library, it detects one at, but after a few attempts it fails to connect.
If I try to set the library at, nothing changes - it attempts to open again.

Perhaps it’s something very easy, but what can I do to connect to my library?
Do I need a static IP on my PC? Roon Remote seems to try to connect through internet, over a different domain;


What is the IP of your Android tablet? It appears to be getting an IP through DHCP in the range.

Why is your Windows PC setup in You either need both in 192.168.0.xx OR – otherwise you’ll need to set up routing.

What happens if you change the static IP of your PC to

IP address of tablet is

There you go. Is there a reason the PC is at Can you set it to

1 Like

I think the static IP on PC is for home network, whereas for internet it uses the gateway server which assigns IPs.
However, I removed static IP and set DHCP so all IPs are assigned by router. The tablet quickly sees library at - it even shows “version 1.1 (build 102)” and the correct library name. It tries to connect but it fails.
PC and tablet do see each other, but there seems to be something that prevents full exchange.

Accept connections from remotes - ON
Firewall - OFF

any setting for accepting incoming signal?

What can I check?


By going wireless on the PC, it made easy for PC and Tablet to connect.

Hi Gianluca,

What Windows are you running ? There are reports online of network connection issues being resolved after all updates are applied.


I am fine now. My test machine is running Windows 7 Home.
It seems that the problem was PC running network on cable, whilst tablet was wireless. The two had difficult to communicate. Once I switched to wireless for PC too, connection was easy.

Incidentally, I would like to report that I was able to use Samsung Galaxy Tab 2 10.1" (GT-P5110) as a remote tablet, although it is not on the Roon list of supported tablets.

The Samsung is a very common tablet, but since it has an old non-updatable Android version (4.2, I think), it cannot work with Roon which needs minimum 4.4 or higher. So I decided to give it a go. Following the instructions of this hack, I was able to install Android. 5.1.1. In the video link there are also detailed written instructions on how to upgrade which you can print out.
WARNING - If you do not feel confident to do so, however, please ask someone who is handy with Linux and general phone updating otherwise you risk to compromise your whole tablet.

After upgrading tablet and downloading Roon Remote, I used Roon on my wireless home network with no problem - it was absolutely pleasant, smooth and without hiccups.