Cannot connect Roon ARC to my Mac M1 Mini Core (Eero 6 Pro)

First time attempted to connect my roon core on my Mac M1 mini. Checked my eero 6 Pro settings UNPN is “ON”. the Arc window recognizes the correct IP. Here is the information that the program gathered, of course I don’t know what it means and I am not competent to do more than follow support. So any help will be appreciated. I downloaded the ARC app to my iPhone 12ProMax. ARC works in delivering music but when in the main program on my M1 Mac Mini, I am informed by the program that ARC is not connected, here is the report:


“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},

“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},

“natpmp_autoconfig”: {“status”:“NotFound”},

“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}

I have no idea how to activate ARC for my main core to my wireless devices. Or to my iPhone 12ProMax 5G which now has the App. It is what I am seeing on the main core program that indicates ARC has not been activated. What am I to do to make it workDHCP & NAT are on automatic; UPnP is “on”, client steering is “on” Thread is “on”. I haven’t a clue how to proceed. Any advice? Best, Richard

Hey @REShaman,

Thanks for sharing all the information that you have already. I’ve notified our technical team (@support) about your post, so they can get started on offering help.

In the meantime, would you be able to fill out the gaps with the information that’s missing from the template below? The more information our team has, the better able they are to help :nerd_face:

Roon Core Machine

Include your operating system and machine info (Model, CPU, RAM).

Networking Gear & Setup Details

Your networking gear (model of routers/switches/etc), connection types (Wifi/Ethernet), and any firewalls, antivirus, or VPN software.

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.

Number of Tracks in Library

Tell us how large your music library is, eg. “30,000 tracks”.

Description of Issue

Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated!

![image|640x320](upload://zD9s6Uqym09anTXYyBbw4FeGmiS.png > Roon Core Machine:

macOS Monterey 12.6

Mac Mini M1, 2020

Chip Apple M1

Memory 16 GB

Verizon FiOS Gigabit Modem(1000 up 1000 down) to main eero 6 Pro with 2 additional extensions

the main eero Pro 6E WiFi router is connected by ethernet, the mac Mini is employing eero Pro 6E WiFi extensions (no ethernet connection)

Turned off VPN on Norton 360. Monterey has firewall but roon has long since been added. I have been a roon client since its inception.

My Dad: Wyred 4 Sound Dac2 SE Upgrade is connected from M1 by USB to Wyred 4 Sound STP Pre Amp and to two Wyred 4 Sound Mono Block Amplifiers. NO HDMI. No Comcast. Roon, Amarra Luxe, Audirvana, Studio, all operate on my system. I have Qobuz subscribed and integrated with roon. Running the latest roon. I have a iPhone 12ProMax running latest 15.XXX software with Roon Arc. I have a remote on my iMac 2018 with 27”Retina. Running Monterey 12.6 on iMac.

Roon: 2122 artists; 5145 albums; 65,642 tracks; 6965 composers.

Eero Pro 6E: In addition to 160 MHz channel support, eero Pro 6E provides access to the 6 GHz band, which frees up the 2.4 & 5 GHz bands (on tri-band systems) to operate more efficiently; eero Pro 6E supports fast speeds and direct access to the 6 GHz band when using Wi-Fi 6E devices, resulting in lower latency across your network, even for non Wi-Fi 6E devices; eero Pro 6E works as a smart home hub so you can control supported Thread and Zigbee devices with Alexa. It also doubles as a border router to facilitate connections with Thread-enabled devices. Wi-Fi 6E Tri-band concurrent 2:2:2 (802.11ax) with support for 160 MHz channels in 5 GHz and 6 GHz, compatible with older wifi standards 1 GHz dual-core processor, 1 GB RAM, 4 GB flash storage; One auto-sensing 2.5 GbE and one auto-sensing Gigabit Ethernet port for WAN and/or LAN connectivity; Profiles, WPA3 (eero Labs feature), WPA2, TLS v1.2+, VPN passthrough, IPv6, NAT, UPnP, port forwarding, DHCP, static IP, and cloud connectivity. Profiles, WPA3 (eero Labs feature), WPA2, TLS v1.2+, VPN passthrough, IPv6, NAT, UPnP, port forwarding, DHCP, static IP, and cloud connectivity. Wi-Fi 6E stands for Wi-Fi 6 Extended. Wi-Fi-6E helps clear the way for faster speeds on more devices, thanks to recently authorized access to the 6 GHz band. In addition to 160 MHz channel support, the 6 GHz band offers a whole new wifi “lane,” freeing up the 2.4 & 5 GHz bands on tri-band systems to operate more efficiently, which is particularly helpful to mesh networks.

I sent roon the diagnostics in my post as I was directed to the Community, which read:


“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},

“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},

“natpmp_autoconfig”: {“status”:“NotFound”},

“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}


Screen shots? I attempt to add ARC and i get the screen that brings me to support: See below. I checked my settings for the eero 6 Pro; UPnP is

“on”/automatic. I have no clue what would stop roon and my system from joining. This is not my area of competency. The problem I am having is that when I attempt to join ARC in roon settings, the screen shows me what is below. I finally got the diagnostics to print what you see above. I don’t know what else to provide you with. Any help that allows me to actually join ARC with roon will be appreciated.


Richard Eric Spatz

Hi @REShaman,

Here’s a fix that worked for another user and my colleague @connor helped with.

Another user with Verizon Fios reported that disabling UPnP on the ISP router and then setting a manual port forward in the router GUI allowed for stable port forwarding. They did have an additional router in their setup, however, which you don’t appear to have. Here’s their post:

It essentially says that upnp might need to be disabled on your ISP router for any router port forwarding to work. I might also add that if you can’t find a way to do that on your own, typically ISP support is best because they’re familiar with their own device’s settings.

From there, you’ll need to set up forwarding on the Eero. Here’s an article I found from Eero that may prove useful.


1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.