Cannot connect to BeoSound 1 via Chromecast


I’m currently in the middle of my 14 day trial and very impressed so far.

I am trying to connect the Roon Core (running on a Surface Book 2) to my Beosound 1.

The Beosound will show up separately under both Airplay and Chromecast in the Audio menu. I can enable it under Airplay, but, there is no sound (unsurprisingly as the computer is not a mac I suppose), but clicking ‘enable’ on the chromecast does nothing. Chromecast is enabled on the Beosound.

I also can’t get sound on the BeoSound via bluetooth, but it does work on other products (like the Beolit 17).

I’m operating on Windows 10, fully updated
Microsoft Surface Book 2 w/ 16GB RAM, 8th Gen Intel Core i7-8650U
Library is stored on an external hard drive and is around 30,000 tracks, mainly FLAC files.

Any solutions for this? Is it Roon or the BeoSound that I should be focused on?

Thanks in advance.

There was a Roku thread implying that only physical chromecasts work.

Thanks for the quick reply. This looks to be a different situation than the Roku. The BeoSound is visible as a chromecast device (unlike the Roku) but I can’t enable it.

The roon release notes say that ‘most’ devices with chomecast built-in, (like the BeoSound) should work. Hopefully this is one of them.

1 Like

Hi Matthew, I have a Beosound 1 and connect to it with Chromecast. Did nothing special though but simply enabled this in Roon as a device. Maybe restart the Beosound 1 as well as Roon?

Hey @Matthew_Quillinan — Thanks for reaching out!

So we can better assist you, may I ask that you please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

As mentioned above, can you try rebooting your Core machine, BeoSound, and networking hardware? Is there any difference in behavior after doing that?

Can you confirm whether or not there is any active antivirus or firewall on the Core machine? Does disabling them yield any changes?


1 Like

Thanks. This has been resolved and things are working now. It looks like my firewall settings were preventing the connection.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.