Cannot connect to Core with Roon Arc

Roon Core Machine

Mac Mini 2.3 i7 , 16gb Ram

Networking Gear & Setup Details

Bt Smart Hub 2 / connected to core via Ethernet cable / no vpn / checked settings and all port forwarding on

Connected Audio Devices

Currently only connected to iPhone

Number of Tracks in Library


Description of Issue

Arc won’t connect says not ready issue connection to core

Can supply diagnostic data if needed
Looking in advanced settings in the router I can see that UPnP is enabled and also extended UPnP.

Settings are default


Allow all outgoing connections and block all unsolicited incoming traffic. Games and application sharing is allowed.

What do the Roon ARC settings show in the Roon remote? “Ready” or an error?

Shows not ready

Please copy and post the error message that it shows. Most likely your port forwarding setup is not working

To add I tried doing the suggested work around in the routers section for my router smart hub 2 and it made no difference what so ever so I set it back to how it was originally.

Here’s my log file

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“Did not find UPnP service with WANIPConnection on network”}

If anyone can make sense of that !!.


together with

found_upnp”:true,“error”:“Did not find UPnP service with WANIPConnection on network”}

is often caused by incorrectly configured ports, such as a port number mismatch or the UPnP autoconfiguration not working. The latter seems to be common with BT Smarthub. See the suggestions in this Roon staff posts:

If this doesn’t help, I’m afraid we will need screenshots of your Smarthub settings

I tried 1. Toggling the UPnP off and on that didn’t do anything. I don’t have a clue as setting 2. Up ?. I’m not that computer savvy to tell you the truth I was expecting this to be a breeze and am a little disappointed that one of the most common routers in the Uk seems to not work out of the box with Arc. There must be 100 of thousands of folks with these l routers?.

Within the linked post, the first post link is to someone with a BT SH 2 and turning off the IPv6 support fixed it right away.

Not much Roon can do if the most frequently used router in UK is buggy…

I see you are posting screenshots while I am writing this, good :slight_smile: I’m sure someone with the same router will be able to help. I don’t have one but let me take a look

1 Like

Apologies I don’t know what screenshots are needed which will offer assistance. I did try the IPv6 method of turning from stateless to off earlier this evening and saving and rebooting the router but that didn’t alter anything sadly

These are exactly the right screenshots. Seems straightforward enough in the screenshots. First, make sure to disable UPnP in the first screenshot. Then set up a manual rule in the page from your second screenshot as follows:

  • Rule name: Roon (this is just a name)
  • Select device: probably you can pick your Mac mini by name from a list
  • External and internal ports: Look up the port number Roon is using, in the Roon ARC settings in the remote. Then enter it 4 times here in the 4 fields. (There are 2 fields each for external and internal because it would be possible to enter a range of ports, but Roon uses only one, so enter the same number)
  • Protocol (half cut off in the screenshot): you can probably choose TCP or UDP here, pick TCP

Like this in the SH thread (use the port numbers your ARC settings tell you in the remote):

(Leave the IPv6 off)

Let’s see how this goes

1 Like

It seems to have done something positive altering a few of the things you mention.

Can I ask does disabling UPnP have a negative effect on anything else for example streaming tv programmes

What solved the issue I hope was setting a new Port Forwarding Rule with reference to Roon as you kindly suggested I have left UPnP switched on and it seems to be working

Thanks Wayne

Thanks for the advice , it seems to be working after doing the port assignment.

I’ll see how it goes over the next days .

No. Only if you have other devices that need a connection from the outside similar to ARC, such as for online gaming. But you would probably know

1 Like

That’s great, everything looks good, well done, that wasn’t so painful :slight_smile: Enjoy your ARC!

1 Like

I’ve left it on and it seems to be working by assignment of port independently.

1 Like