Cannot connect to Nucleus after updating to 1.8 build 933

Roon Core Machine

Nucleus+

Networking Gear & Setup Details

Google WiFi access point:

  • WAN connection goes to cable modem
  • LAN connection goes to ethernet switch
  • Nucleus+ is connected to same ethernet switch

Connected Audio Devices

Sonos Play 5, Bluesound Node 2i, MacBook speakers

Number of Tracks in Library

a few thousand

Description of Issue

After updating my Roon Nucleus+ to Roon Server version 1.8 build 933, I am no longer able to connect to the server via the Roon app on my MacBook Pro or on my iPhone. However, I am able to connect via the web interface on the same MacBook Pro. The web interface confirms that everything is running and that the server version is indeed 1.8 build 933. Additionally, I am able to connect to the Nucleus+ file system (smb://NUCLEUSPLUS) via the same MacBook Pro. Tried the following steps without any success:

  • Restarting the server via the web interface does not fix the problem
  • Rebooting the Nucleus+ via the web interface does not fix the problem
  • Closing/restarting the Roon app does not fix the problem
  • Clicking “help” in the Roon app and entering the Nucleus+ IP address manually does not fix the problem. However, connecting to the same IP address via a web browser on the same MacBook Pro successfully connects to the web interface. I’m also able to ping the IP address successfully from a terminal on the same MacBook Pro
  • For what it’s worth, I verified that the Nucleus+ is among the list of devices connected to my Google WiFi network when I check the Google Home app

Also verified that all devices are on the same IP address subnet:

  • Nucleus+ confirmed by the Google Home app as having a wired connection with IP address 192.168.86.41
  • MacBook Pro has WiFi connection to the network with IP address 192.168.86.33
  • iPhone has WiFi connection to the network with IP address 192.168.86.30

Summary: I’m able to connect to my Roon Nucleus+ via the web interface and I can mount the filesystem and see the contents. But I cannot connect via the Roon app. Restarting the server and rebooting the Nucleus+ did not help.

How can I troubleshoot further?

I also cannot connect to my nucleus with any of my four Apple remotes after the latest update. Tried most everything I could think of. Just thought you’d like to know UR not alone and I am at the point where I am going to stop chasing my tail and wait for a fix.

Did you update your iDevice apps?

1 Like

Just updated the iPhone app via the app store. And downloaded a fresh install of the Roon remote for Mac from Roon’s web site. Unfortunately this didn’t help on either device. On the Mac I still get endless “Looking for your Roon Core” (and entering the IP of the Nucleus+ directly doesn’t help), and on the iPhone, endless Roon icon without any text.

Did you reboot your Roon core after updating your iDevices?

Whoa, this is bizarre. I decided to try on a Windows PC I have lying around. I got an unexpected result.

When I connect to the Nucleus+ via the web interface on the Mac, it says that the server software is running:

But on the PC, the web interface (using the same IP address) tells me that the server software is not running:

Just restarted the server via the PC web interface. Unfortunately Roon still can’t find the core on the MacBook Pro or the iPhone. Additionally, I confirmed that it also does not work from the Roon app on the PC.

Aha, this turned out to be an important clue! Notice that in the Mac screenshot above, it says that the server software has only been running for 10 seconds. By refreshing every couple of seconds, I can see the the server software appears to be in a reset loop: it comes up and is reported as “OK” for about 15-20 seconds, then “Not Running”, then “OK” again but with the running time reset.

I guess this means that the software update failed somehow!

Is there any way to recover from this without having to factory reset the Nucleus?

Update: I decided to bite the bullet and “reset Roon database and settings” via the web interface. This failed on the first attempt and I was afraid I may have bricked it as a result. But fortunately a second attempt succeeded, and now the server is working! I’m able to use Roon on all three of my devices: MacBook Pro, iPhone, and Windows PC. Unfortunately, when you do this, it resets all of your setttings to the default, so you have to reconfigure things like preferred album display settings, EQ profiles, etc. But at least it’s working!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.