Cannot Connect to Nucleus +

Roon Core Machine- Nucleus +


Nucleus+, Roon OS 1.0 Build 227, Version 2.0 build 1128

Networking Gear & Setup Details

Netgear GS105- for Roon and Lumin U2, networked into a GS108, all hardwired via Ethernet.

Connected Audio Devices

Roon to Netgear switch, Lumin U2 to Netgear, Roon to Lumin via USB

Number of Tracks in Library


Description of Issue

I am not able to connect to the Nucleus core. I have unplugged at least 15 times, powered on, and off. Replaced Ethernet cables, I even bought a separate switch for only the audio (lumen and Roon). nothing has worked. I am using Roon 2.0 in both my MacBook Pro and all associated hardware.

Initially I will get a message connecting to Roon, and my core will show up (only after powering off) I have a red dot stating (connecting). Then it never connects, then the screen changes and says, looking for Roon core.

This is getting beyond frustrating! Especially for what this service costs!

Have you ever connected?

If so, then your Nucleus may have developed a problem with its OS drive. Can you connect a monitor to it and see what messages are displayed at boot?

Check the date of purchase of your Nucleus+, see if you still have warranty for it or not.

The warranty expired a month ago. I’m assuming it has a 1 year warranty. The first time this happened it was within 1 year, which would’ve been late July. I was then able to get it to connect later many on/off cycles. So whatever the issue was then, has now become permanent. Roon, should have a customer service number like every other company. It is absurd the only way to get help from them is to post on this forum!

Yes, worked great until it was around 11 months old, which was in July/August. I had this issue, and posted on here about it. It eventually reconnected. Now I’ve been trying to get it to connect for over a week and nothing! Of course now its 13 months old and is out of warranty.

Nucleus usually comes with 2 year warranty.

1 Like

That would be great news if it is the case.

@support will probably ask you to connect a monitor to see if anything is displayed.

Hi @Mike_Tennant,

I’m sorry you’re having issues with your Nucleus. I understand this can be frustrating (Nucleus user myself) but we’ll get this figured out.

Please connect a monitor to the HDMI port on the Nucleus and let us know what you see. Posting a picture here will allow us to help you further.

If you see nothing, please refer to the private message I’ll be sending you momentarily.


This topic was automatically closed after 45 days. New replies are no longer allowed.