Cannot connect to Qobuz

Core Machine (Operating system/System info/Roon build number)

ROCK on Intel NUC / Operating System: Version 1.0 (build 227) / Roon Server Software: Version 1.7 (build 667)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet, Router: FritzBox 7590 (I live in Germany), Switch: Uptone EtherREGEN

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Remotes: iPad Pro 2 iOS 14.1, iMac MacOS 10.15.7

Description Of Issue

As of today, I cannot connect to Qobuz. When I put in the account info, the error message states a “network error”, both on iMac and iPad. But the Qobuz App works fine on both remotes.
Qobuz is the only service I use, so it is very annoying.
The system has been working perfectly for years now. The problem started last night with loading errors on Qobuz titles, so today I started by reinstalling System and Roon Server Software on the NUC. That is how I lost my connection to Qobuz and could not log in any more through Roon.

It seems that last night Qobuz had some troubles:

Thanks for the link. But Qobuz is not the problem, because in works fine in the Qobuz App and in the BlueSound App on the NAD M10. I just cannot log in to Qobuz in Roon.

Do you still have an issue?
I live in Germany as well, with 7590 and NUC.
Had Qobuz all day, just restarted the NUC and stilll have Qobuz, noticed no irregularities atm.

Hi @Hermann_Battenberg,

Does a reboot change anything?

Were there any changes to your setup (new devices, updates, etc.) around the time this started occurring?

Thanks for responding.
I rebooted the NUC, also the remotes, but I can still not log in to Qobuz.

Sorry, I didn’t answer your second question. No, there have been no changes lately, no new devices or updates.

I tried something else: I disconnected from my ROCK, installed a core on my iMac, and ran Roon from there. In this setup I could connect to Qobuz without any problem.
After this, I disconnected from that and tried again from ROCK on my NUC (after rebooting it again) - same as before, I could not log in to Qobuz, it returned a network error.
I hope there is a solution, my system worked so well before!!!

Hi @Hermann_Battenberg,

Thanks for confirming that the iMac does not have this same issue, we should focus on ROCK in that case. Can you please provide a screenshot of your ROCK’s Web UI? It should look similar to this for reference:

Thanks. It is an Intel NUC8i3BEK.

1 Like

Hi @Hermann_Battenberg,

Thanks for sending that screenshot over, it looks as expected. As for next steps here, I would try to clear out the Roon cache:

  • Exit out of Roon
  • Stop RoonServer via the Web UI
  • Find and open your Roon database
  • Navigate to RoonServer/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

Hi @noris,

I did the steps, but unfortunately no success. It still reports: “Network error: Please check your connection”.
Should I copy the cotnents of the Cache folder back to ROCK, or does it not matter?
Should I reset the Roon Database & Settings in the ROCK Web IU? (I have avoided that until now, so as not to loose the data of my hundreds of Qobuz records.)
Does the ROCK installation have any networks settings I could change?

Thanks for all your help!

Hi @noris again,

Maybe it helps if I send you some network info from my router. Unfortunately it is all in German, but I tried to put in some translation. Maybe the fixed IP address is a problem? But I have had it set up like this from the beginning in Feb 2019.

Hi @noris yet again,

I fiddled with the IP settings on the NUC - and I had success!!!
I changed to a fixed IP address and changed the DNS server. That did the trick, I could log into Qobuz and Roon is running fine so far.

Thanks for your efforts. Maybe this will help somebody in a similar situation.

Kind regards

Hi @noris,

…well, actually it didn’t work that way. I realised that Qobuz did not load content at all. After a reboot I could not even log into the NUC core anymore. I restored everything from backup, changed the NUC back to DHCP, and changed the DNS server to in my router. After rebooting the NUC again, it finally worked! Took me the whole Sunday, but it was worth it. I made the experience that playing music from the BlueSound App or the Qobuz App is no comparison to Roon, having all the information at hand and being able to choose exactly what you want to hear easily.


Hello @Hermann_Battenberg,

Happy to hear that the issue is resolved since restoring the database! If you have any further issues please do let us know and we would be happy to take another look!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.