Cannot connect to Roon Core after updating to Android 10 / Emui10

Innuos Zen with Roon core v. 1.7 build 555

I have today received and installed the latest Android 10 / Emui 10 on my Huawei P20 Pro.

After the update Roon Remote cannot connect to my Innuos Zen. Fortunately I also have an iPad, which still operates flawlessly.

I have tried to reinstall the remote app (twice), and so far the only luck I have experienced is, that the app is able to connect after a reboot of the Zen. But only once.

Do You have a fix for that? And please do not sent me investigate every aspect of my network, as nothing has changed but the update of my Huawei handset:
Everything is on the same network
Yes, the Zen is rj45-connected
No, there are no switches between the Zen and the router.

Everything was working fine on the handset when being on Android 9 / Emui 9.

So the error can only be located to the combination of Roon Remote and Emui10.

I know it’s no consolation but I have upgraded my Honor V10 to Android 10 / Emui 10 last week and all is well. The phones aren’t a million miles away in spec. I’m using Roon ROCK on an NUC.

A factory reset on the phone seems a bit drastic but could be worth trying?

Hi @Torben_Grell,

Are you still able to manually connect to the Core by specifying the IP address or the multicast address of You can specify the IP by clicking on the “Help” that appears after being on the “Searching for Core” screen for 60s.

Do you have multicast turned on in the router? I would check for IGMP Snooping/IGMP Proxying as these settings have helped with multicast issues in the past.

Hi Noris
That did the trick…entering the IP-address manually. In fact I did not know of the feature of “Connect to a different core”, as it states a warning of loosing everything. Maybe You should refine the supporting text of that possibility, so it is clear, that You can connect manually to your core through this possibility.
But anyway it works, and in fact first connected it actually seems to work faster in searching albums and through Qobuz.
Is the default communication from app to core always initiated through a multicast request?
Regards Torben

1 Like

Hi @Torben_Grell,

Glad to hear that connecting directly via IP worked!

Yes, Roon uses multicast for device/Core discovery, and from what I have seen, Android is more sensitive to improperly configured multicast networks.

It is possible that the OS change also changed something with regard to your Android devices internal multicast setting.

In any case, glad to hear that manually specifying the IP works, if you would like to look into this even further, my suggestion would be to see if you can find IGMP Proxying / Snooping settings on the router or even on the Android device itself.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.