Cannot connect to Roon Core (suddenly!)

Roon Core Machine

Roon is running on my Small Green Computer Sonictransporter version 2.8. It runs on Sonicorbiter OS. It has Roon Server Ver,1.8 build 923 stable.

Networking Gear & Setup Details

I have Netgear Nighthawk > Etherstream Switch>long ethernet cable to>Etherregen> Optical Rendu> Singxer SU-2, switching USB to i2s> i2s goes to my HoloMay DAC. I also have a Schiit Freya+ preamp and powered Focal Solo6 BE speakers.

Connected Audio Devices

See above. P.s, I’m using HDMI cable for the i2s connections.

Number of Tracks in Library

~7500 albums and ~ 1100,000 songs

Description of Issue

Suddenly, the music stopped and got message that it’s not connecting to Roon Remote.
After a while I tried to “change Roon cores” and got new message “Choose your Roon Core” and below that: “Looking For Your Roon Core” that went on without stop, wit h the Roon logo churning (it’s still churning right now as I write this letter!)
I have tried: turning everything off and back on, including the Sonictransporter, which is the Core (right?) I was listening to music when this happened. The only “new” thing that occurred is that I installed a new HDMI cable for the i2s. It was working fine for about 40 minutes when I lost touch with the Core. I lost touch just as I was changing to a new album,Fwiw.
Everything SEEMS to be running just fine except for connection to the Core!
It’s now been about 7 hours and still no luck. I cannot wait to hear back from you for help. I am 100% stuck!
Thank you,
Geoffrey Cole

Hi, @petridish, thank you for the report. Could you, please, follow the instruction described in this article here and share with us a zip archive with log files from your RoonCore on Sonictransporter.



hi Ivan,
Thanks for responding. I need some help (this stuff is sometimes over my head!) I was able to download the most recent Log File from the Roon Core but I have it in TXT format and don’t know how to convert it to ZIP for you. First, can I send it to you as a TXT file and, if not, can you tell me step by step how I would convert it to a Zip file for you?
Also, is there anything else you need from me besides the Log File?
Thanks for your help.
Geoff Cole

Hi Ivan,
Well… I did figure out how to make a zip file from the text file, fir the Roon Core Log. Now I just need to figure out how to attach it to this e-mail correctly!
OK, I just tried to send it to you and got a message that it cannot be “uploaded”. So, I don’t know what I’m doing wrong.
One thought: could I send this zip file to you by regular email? I would just need your email address!
Thanks for your help. I wish I were better at this and could save you some trouble!

Dear Ivan, It took me a while to figure it out (and to purchase Dropbox!) but I think I sent the link to you correctly! Please let me know ASAP if it didn’t work. I am really missing the music, so hope to hear from you soon about next steps in fixing this!
All The Best,

1 Like

You need to zip the whole logs folder ideally.

dropbox is free for minimal account needs

maybe check with SGC too @agillis as they should be able to remote to check on things

@petridish I just sent you an email. let me know if you are still having issues.

If nothing helps, maybe try this:

1 Like

Hi Ivan,
With the help of the great Roon community, it turned out to have a super simple, though utterly non-intuitive solution: I turned off the Local Playback box under Roon Server Settings in Sonicorbiter. This little “toggle” did seem to wake up the Roon Core or something equivalent and now it’s just fine!
Thanks, everybody for the help — and I hope this helps the other folks with the same problem!

1 Like

Hi Ivan,
I’m sorry to report that there is STILL a problem with being unable to connect to the Roon Core! It IS connected, somehow, with the 2 boxes on Sonicorbiter, under Roon Server Settings: “Local Playback” and “Expose Roon Database”. The Core connection is going off and on, but it seems random- not connected specifically to which box is on and which is off. As others have noted, it definitely started for me when Roon Server. Build 923 came on board so, does seem to be some software problem — and as big one since it definitely shuts off access to the music!
Please respond to let me know how you guys are working to solve this (very frustrating!) problem.


Hi Ivan,
This will give you a idea of how this problem of connecting with the Roon Server is persisting (i.e. NOT yet solved).
I have had two iPads for many years, both running Roon perfectly- even at the same time. Now, however, one of them will not connect to Roon Server no matter In what combination I check or uncheck the 2 boxes in Sonicorbiter (“Local Playback” and “Expose Roon Database”).
So, I DO have one iPad working now, but I’m not sure this will last and it’s ridiculous to be worrying every time I turn it on , that it will have “reverted”.
Anyway, Can you let me know you’re doing sorting this out?
Thanks again so very much for your help!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.