Cannot delete albums from library

Hi @benjamin

This note is just to express my enthusiasm to get this resolved as I am currently unable to delete any Tidal albums from my Roon library. I created my own support request for this a week ago (ref#90TG6K) but my case was closed


Hi @Matthew_Jobling,

Our team is still investigating potential causes behind Tidal syncing issues. That said, I believe you may be experiencing additional issues outside of this. I’ll re-open your merged thread to explore this further.

Same here! Deleting Tidal albums is not possible anymore. After the errors, the only way to remove the album is to reset the Roonserver.

Hi All,

Are you still experiencing issues on the latest Roon production release?

Let me know, thanks!

Hi @benjamin, it seems to be solved with the latest update (at least for me it is).
Even a very reluctant album that wouldn’t disappear could be deleted from my library without errors.


Works OK now again. Good work.

Ooops find more albums not possible to remove.

When Unavailable I get the File not available message when try to remove. If I try to move again, no message.
The issue seems still be there.

I am living in Belgium, and I do not find any entry for neither artist ‘Marian Herzog’, nor album ‘Rebell’ in Qobuz.

In your screenshot, you seem to have 2 versions of this EP, as it the one shown is a Duplicate.

What I would try to do, is 1st show the 2 versions, and check if one of them is still available (or not).

Re-identify the one(s) that are not available, in an arbitrary - completely different - album that Roon proposes, in order for Roon to actually write in the Database record for this album. Once identified, remove that ‘re-identified’ record.

If re-identification in something else does not work, try to Edit the album.
As long as it is possible to get Roon to write something in its Database, one should be able to remove the album.

That is the problem. It’s taken away from Qobuz, but I cannot remove it from my library then. I have already tried re-identify, re-scan, analyse but nothing happens. If I make a backup of whole library and restore it. Then it’s gone. Sounds like index have it left but not the database and when I restore the db, the index is recreated.

You might be aware of that, but did you try cleaning up the library using Setup > Library > Library Maintenance particularly removing the unavailable/not associated tracks? That was in similar cases doing the same job without the backup restore. Admittingly I did not try it with Qobuz tracks being removed from their portfolio.

Yes, I have tried that too but there is nothing to maintain.

Sorry if this is redundant, but did you re-identify as a completely different album, i.e. different artist, different album title?

The issue seems to now be resolved for me. Thank you very much for any efforts made on your (Roon staff) part to fix it

1 Like

Nope, still got an error this morning, deleting a Tidal album. So unfortunately not as stated before. Unsolved
Some extra information: both albums that triggered the errors (and couldn’t be removed from the library other than restarting Roonserver again) were added to the library in the Tidal app, so not in Roon directly.

Hi @RM_Kamphuis,

Thanks for the update.

Can you confirm they were fully added and synced to your Roon account prior to attempting to remove them?

@Rainer_Lainio are you still experiencing issues? Let me know your status, thank you! :pray:


Seems to work better now. I removed some older unavailable and tested also with available, from both Qobuz and Tidal, without any issues. Thanks :- )

1 Like

Yes @benjamin, after adding the albums by liking them in Tidal, they showed up in Roon (this takes a while). I assume that when they appear in Roon, they are added and synced? Or does that process takes longer?

If you add something in Tidal/Qobuz, instead if waiting for the resync cycle, you can resync immediately by going to settings services, choose your service and then click the blue Sync Library Now .

1 Like

Thanks @Rugby. Just tried this at home (which you normally don’t :wink: ) and it seems to work.
The earlier errors probably were caused by Roon not ready with the syncing part.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.