Cannot delete albums from library

Content you’re reporting an issue with

Cannot delete any albums from my Roon Library when songs unavailable at Qobuz or Tidal. This have been possible before.

Have you made any edits to this content in Roon?

No

Is the album identified in Roon?

Not from begin but if I run rescan, re-identify or re-analyze it goes to Unidentified.

Is this content from local files, TIDAL, or Qobuz?

It is at Tidal or Qobuz content.

Screenshot of import settings



Description of the issue

Songs Unavailable.


Error when trying to remove the album from library

Nothing happens or I get a message “Cannot remove ## files from library. Unavailable”

Try this:

  1. Go to (….) > Edit > Re-Identify album
  2. Choose any version, doesn’t matter which
  3. Try deleting the album again
1 Like

Thanks, done that already. Did not work. Thought I make a backup and restored it and then all the deleted albums were gone. Still when I tried to delete new albums that are unavailable, I get same issue again. It will not delete it. Strange???

It is strange

1 Like

Have this massage after first remove try, but these files (music) is not on my harddrive. They are on Qobuz?

I’m currently in a private conversation with a different user who has exactly the same problem. I will send them here :slight_smile:

I’ve tried to add some random album and removed it again. This works for me, does it for you?

If I add a new from Tidal or Qobuz, I can remove them, but for now no albums I have added for a while ago are not possible to remove from library, even if they seems to be available. Same “file not available” message. Did not see this coming with older added available albums. Was only testing albums added like this week and could remove them when they where available.

Strange. No idea, best to have Roon support take a look

Hey @Suedkiez This happened to me just before I got the current issues with Tidal. It’s like the sync is randomly dropping albums/songs off. In my case, I believe IIRC I closed completely out of Roon & Server. Rebooted a Roon Sever and then ran Services sync a few rimes. The Album ended up appearing 3 times in Roon, but then finally I was able to delete it…Edit:/them it is definitely weird but could be tied in with current issue a number of users seem to be experiencing.

What’s happening?

· Something else

How can we help?

· None of the above

Other options

· Other

Describe the issue

When I try to remove albums from my library I receive an error stating "These tracks could not be deleted because they were either not found, or because you don't have permission to delete files from the hard drive". This is a brand new issue for me as of today. After rebooting my core server I see that the albums in question have disappeared, but if I try to delete any more albums the issue reoccurs. So far only tested deleting Tidal albums

Describe your network setup

Simple wired setup with Windows PC directly connected to Asus router. No changes made here and no connectivity issues occurring

Just a short note to add that no changes have been made to any aspect of the core/server system today

Thanks everyone for a wonderful product that I’ve enjoyed religiously with full license for years now

Something is going on. There is another case here:

1 Like

Yet another one:

Interesting, and weird :slight_smile:

I tried deleting a few albums from the past weeks and they all worked for me (but I’m on Early Access)

1 Like

Thanks Suedkiez. Great to be validated!

1 Like

-small tweak on my original description of the issue

Hi @Rainer_Lainio,

Thank you for the help here @Suedkiez! Our team has a ticket in to investigate these sync issues further. We’ll share any new information found as soon as possible. Thank you for your patience in the meantime! :pray:

2 Likes

Yes, this is also happening to me - all Qobuz added albums I try to remove brings up the same ‘Some tracks were not deleted’.
Haven’t tried my local albums as I don’t want to remove those.

A post was split to a new topic: Cannot delete albums added form Qobuz