Cannot discover Roon Core anymore; Core cannot control other devices

Roon Core Machine

2 different Windows 10 laptops:

  • [PRIMARY] Lenovo W530 with latest patches and updates
  • [SECONDARY - a new setup solely to identify whether issue was with old Lenovo laptop] Brand-new Dell XPS 17 (9710) with latest patches and updates

Networking Gear & Setup Details

Router: Google Nest Wifi routers and 3 mesh extenders

  • Lenovo core was connected via wired Ethernet to router
  • XPS 17 is connected wirelessly

Connected Audio Devices

  • Chromecast audio
  • Windows 10 laptop running Roon app
  • Pixel 5 phone running latest Roon app
  • Google Nest Wifi speakers

Number of Tracks in Library


Description of Issue

SUMMARY: Cannot connect to the Core from other devices. Cannot get the Core to control other devices.

I’ll try and make this as brief but clear as possible.

  • I have been using Roon for about 16 months now. Set up Core on an old Windows laptop that has been physically connected to the same Google router for ages
  • I use my Android phone as one control point - to browse my library and send audio to Chromecasts attached to hifi. I occasionally send audio to the little Google Nest speakers too
  • I also use my work laptop as another client - mainly to listen to music on that machine when I am working
  • I would sometimes find the Core was not found. This was generally because Windows annoyingly forced an update and rebooted the machine, killing the Core app. I have become accustomed to manually logging in and restarting the client every few weeks (thanks Microsoft)
  • This happened earlier this week (Monday or Tuesday) but this time I found the windows app was still running.
  • Seeing as I could not connect to the Core from my phone, I used my laptop/Core device to select a zone (one of the google speakers) and tried playing music: I could hear the ‘connected’ tone from the speaker, which happens when it received a playback command from elsewhere. However, no audio played. The Core seemed to be slow and confused.
  • I tried restoring from a backup about a week old - when it was definitely working: no joy.
  • Tried deleting app and all settings, reinstalled… restored backup: no joy
  • Installed Roon on my brand-new work laptop (the XPS 17). Restored from a known good backup: SAME ISSUES!
  • I cannot find the Core on my Android phone. Again, when I try to control another device, it seems to connect, but no playback occurs.
  • Once, and only once, I saw a message pop up saying “audio device refused to switch input to roon”
  • I enabled my XPS as a ‘zone’ or whatever it’s called. I can play music successfully.

I am not aware of there being any router / network changes in the last week.

I can’t figure out how to diagnose what is going on. It’s really annoying!

Has anyone got any suggestions at all!?

Disable the windows firewalls and see if things improve. Sounds like a windows networking issue.

1 Like

Short answer: I have now fixed the issue!

I thought it could have been a FW issue so checked settings a couple of days ago and ensured Roon was permitted on private networks and blocked on public ones…

But when I checked Windows Firewall just now, I saw that - even though I am connected to my home network - it said the Public FW was active! Checked network settings and verified my network was categorised as public for some unknown reason. I am confused… what could have changed? And is this somehow synced across accounts because I assume this has happened on all PCs.

Going to look into this, but for the time being - I have a solution. Need to check my old Lenovo next.


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.