Cannot enable Google TV / Nest Hub

Core Machine (Operating system/System info/Roon build number)

Intel i5-8250U @1.6 1.8 Ghz
Windows 10 Pro
Roon 1.8 - Build 764 - 64 bit stable
Evaluating trial version

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

PC and Chromecast connected via Wifi. The router used is TP-Link N300 Wireless Portable Nano Travel Router. It gets the internet via LAN and transmits wirelessly for all devices.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

PC connected to Fiio K5 Pro using USB interface and then to Sundara headphones.

Description Of Issue

I am currently evaluating Roon and so far like the metadata management , discovery of artists or tracks etc., I also use it inorder to do Parametric EQ application so I can send the signal in exclusive mode to Dac.

However, I would like to listen in my speakers as well and my Edifier speakers are powered ones but don’t have Bluetooth. I’ve been listening music through Tidal/Spotify from my Google TV with the speakers connected to TV.

Now, to use Roon so I will be able to easily switch between listening in headphones and then continue in Speakers, I wanted to enable Google TV. It detects as Audio Device as Chromecast with a 192.168 IP address. However, clicking on enable just starts a Roon screen in TV that keeps on loading and finally timing out and going back to Google TV homescreen.

Similar thing happens when i try to enable it as display. I’ve a Google Nest Hub connected to same network. It behaves the similar way when I try to enable it as display for lyrics.

I’ve searched the community and tried possible solutions so far and nothing worked. Can someone guide me to solve this. This is important for me to decide if I stop with trial or decide to go annual or lifetime subscription.

Have you enabled the Chromecast and Nest Hub on your mobile device (Android or iOS) with the GoogleHome app??

Yes I’ve been using the nest hub for years and Google TV for months. Both are enabled and can be controlled via home app.

I use an HDMI splitter with a Toslink output connected to my Google TV. I get Roon output via the Toslink to my DAC without problems. You have to recognize the outputs in the Roon audio settings of course…

Sounds like possibly a network issue Roon requires mDNS and IGMP to find Chromecasts and have two way Comms between them. Are they on the same subnet e.g. first three sets of numbers match. Does the router have anything in settings for these things. What’s the tplink connected to exactly? Another router or modem?

TPLink is connected directly to the LAN in my room. They all have same subnets. The wifi IP of my latop shows 192.168.0 for first three numbers and its the same with Chromecast in Google TV and Nest Hub.

“Roon requires mDNS and IGMP to find Chromecasts”

How can i verify or debug this?

Hey @Senthil_Ramesh_J_V,

Welcome to the Roon community :wave: (12 days too late…)

I am so sorry it took us this long to get back to you. In the hopes that you’re still interested to get this working, I was wondering, did you ever stumble upon this article where we describe how you can use Chromecast with Roon?

Also, have you tried resetting your network?

Thanks in advance :pray:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.