Cannot favorite TIDAL tracks that are not part of library

(Andrey Putilov) #1

The bug still exists ( One month was no problem, but today heart can’t works at the bottom left. Tried restart several times roon player, -nothig happened.

1 Like
Cannot favorite (click the heart)[Ticket in]
(Andrey Putilov) #2

@support Any progress with this issue?

(Noris) #3

Hi @Andrey_Putilov,

Can you please share some screenshots of where exactly you are not seeing the heart work on your end? Is this in the Queue menu or elsewhere? I’m not quite sure what you are referring to as the “bottom left” and some clarification would be helpful.

(Andrey Putilov) #4

Hi,

This is track from Tidal. Heart left in the bottom. I pushed heart and nothing happened.

(Andre) #5

I had the same. I understood I first needed to ADD the whole album to library. And then favorite songs. Does that work for you?

(Andrey Putilov) #6

This album has only one track and I don’t know how I may favorite the whole album (

(Andrey Putilov) #7

Found it. But. Sometimes I see heart, sometimes I don’t see. Here is two screenshots. And heart in the left corner doesn’t work at the both cases.

(Andre) #8

Yeah annoying. Sometimes you dont’t want the whole album to ADD and just favorite one song. Who knows they will change this in the future :slight_smile:

(Andrey Putilov) #9

I don’t know what’s happened, but one month ago I could tap on heart at the left bottom corner and track added to the my own media library and became favorite. Now it doesn’t work.

(Noris) #10

Hi @Andrey_Putilov,

To be able to click on the heart icon, a track has to be first added to your Roon library. It is possible that you were already playing tracks that were already part of your library, and that is why it was possible to favorite them.

We are considering some changes in this area, but the expected behavior at this time is that to favorite the track it must first be part of your library and if the track is not part of your library, you will not be able to favorite it.

(Andrey Putilov) #11

Ok, realize it. Is it possible to add to my library automatically all what I play now from Tidal? May be you add option for this?

(Andrey Putilov) #12

Sorry for my obsession, but here is it my favorite list, what I made month ago:


I tap play A Million Dreams from my favorite list directly:

Did you see that “the heart” is disabled? How can I add this track to my favorite this way that Favorite Heart do not show that is Favorite?

(Andrey Putilov) #14

Guys, there is bug with heart button. I have added album to library. Then favorite it. But can’t unfavorite it. Here is short video. https://share.icloud.com/photos/0NmF3tAFK5Ry6AVWBm6kL9ayA

As you see, I have tried several times unfavorite my track and it fails.
After few minutes, this bug disappears. Something wrong with favorite functionality, please fix it.

(Mike) #15

Let me first clarify when you should expect the Favorite button to work, versus when it should not work.

Content in your library can be accessed from any of the browsers – Album browser, Artist browser, Track browser, etc. Any tracks or albums you “star” on TIDAL or Qobuz will appear in your library, and you should always be able to favorite the content in your library.

Content in the TIDAL & Qobuz browsers are not in your library – these browsers are provided so you can access editorial content (like playlists), browse lists of new releases, and get a direct view of your TIDAL or Qobuz favorites that’s not subject to Roon’s library management features (like duplicate detection).

This view is offered as a reference for completeness sake – it’s simply a straight list of favorites we get from TIDAL, and it’s not meant to provide a fully functional browsing experience or replace your library – in fact, it’s designed specifically to link to the original content outside your library. As such, you won’t be able to favorite content you browse to via this screen.

There’s some more information about the differences between albums inside and outside your library here.

I’ll also mention that we are considering some changes in this area, so you’re able to favorite content outside your library. I don’t have a timeline, so for now I wanted to explain why this TIDAL > Favorites section even exists for albums and tracks, since that content exists in other parts of the app.

All of that said, the video posted above does look like a bug – the more information you can provide @Andrey_Putilov, the better. For example, does this happen every time? What steps are you taking before the recording starts? How can we make this happen in house? If we’re able to reproduce I’m sure we can get it fixed, so thanks in advance for the feedback here.

(Andrey Putilov) #16

First of all, thank you for the quick response!

Let’s discuss first part of my last post. Yes, I understand (now) difference between track in lib and outside. In the faq you wrote (after add library pushed): “You’ll see the page update to reflect newly available options once it’s been added to your library.” See my new video. I choose “add library” and my interface screen doesn’t refreshed and heart (favorite) icons doesn’t appeared. I think this is the first that confused me. If I stop this track and find this album in Recent in Roon, it appears with “hearts”. But I think this is wrong behavior?

https://share.icloud.com/photos/0IwvBALwT_7rZkktP4gcEQ7TA

(Andrey Putilov) #17

About second part with the conformed bug. I do not remember exactly, I think I starter Roon Radio and go forward 2 or 3 tracks and then back…

(Noris) #18

Hi @Andrey_Putilov,

Just wanted to come back to you on this issue, I have spent a bit of time trying to reproduce by going back and forth on Roon Radio tracks and verifying if the heart button is still click-able afterwards, but I have not been able to get into the same state from the first video you sent.

I will request our QA team to have another go at testing for this issue, but if there is any other set of steps that you can use to consistently reproduce this behavior, it would be helpful to know.