Cannot get roon remote to run on a win 10 PC

Hi Dylan , On the PC experiencing the problems (Remote) or the server (the Core) or both?

Never mind, I see from the link it is the Core

Ok I have started the Core and it has generated a new RAATServer file

Hi @Mark_Inboden,

On the PC experiencing the problem. Any change after doing so?

no I did this on the Core that seemed to be what the link was referring too. So I need to do this on the PC where the audio devices are not being discovered ? Is that correct? And can I restore my Core ?

Hi Dylan I just did this on the PC with the Drivers not showing up and Voila after generating a new RAATServer my devices showed up. They also showed up on the Core. I just restored my core and they are still there!! So it appears that the PC that was experiencing the problems is now working!

Thank you and the team for all your help!

I’m glad to hear that this worked for you, @Mark_Inboden! Happy listening :headphones:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

I was working with Dylan in support for the last couple of weeks on a problem with a Roon remote win 10 PC with both realtek and nVidia devices not showing up at all on the network or the remote PC. Support had me recreate the RAATServer file and the devices appeared and all was well. so it worked for that afternoon after recreating the RAATServer file. I shut down my PC and when I rebotted my PC just now I stated Roon and the devices are no longer appearing again. I assume I can recreate the RAATServer file, But that is really inconvenient. Here is the a screen shot of the Audio devices on my rempte PC again:


Oh I meant to mention the original thread closed after 36 Hours which I why I am creating a new thread

Hi @Mark_Inboden,

I’ve moved your other post back to the original thread and re-opened the topic. Sorry for the ongoing troubles here!

I’ve enabled diagnostics once more so we can take a look — I’ll be sure to follow up once I’ve heard from the team.

Thank You Dylan!

I would bet the issue is the Realtek Drivers as they have cause a ton of problems and can cause the issue you are having.

See this thread No Internal Audio Device Found

Thanks and I certainly agree if I only had Realtek devices. But I also have a Nvidia audio Device on this PC. And the problem appears it is Binary. Either they all show up or none of them. If it was the realtek drivers I would assume the Nvidia Device would still show up and the realtek would not. But I will read that thread!

Reading the thread it is interesting that it looks like the exact same problem. However I use this PC fopr Gaming as well and the realtek drivers are actually ASUS’s implementation of SupremeFX. So I am not sure I can uninstall and use the generic MS drivers. It looks like this has been going on for some time is there no work being done with Realtek to fix this?

Hi @Mark_Inboden,

I spoke with the team regarding their evaluation of the diagnostics report. Unfortunately, there isn’t much that can be seen on the Roon side of things. The team believes that this may be an issue with the driver leaking memory which causes Roon to be unable to see these devices.

The team has proposed a test that they’re hoping can clarify further:

  1. Uninstall Realtek drivers and any Asus audio software
  2. Reboot the Core machine
  3. Install Windows audio drivers
  4. Launch Roon and see if the same behavior occurs
  5. After confirming whether or not this resolves the issue you can re-install the Realtek drivers and see if the same behavior appears

Hi Dylan,
I know how to get the Realtek SW and drivers uninstalled. Where do I get the windows audio drivers. I think there was a thread on this, perhaps?