Cannot get Roon running

I would suppose it is this from :

Indeed and a quick Google brings back the thread on running 500k+ tracks.

I read Brian’s post. The is referencing an i7 with 8GB of RAM and an SSD Boot drive all of which I have. I went the extra distance to run the Roon Rock Core He is also referencing a perfect experience and I cannot even get the remote to load. I poured through the KBs to get the specs and even listened to the Von Beekhuyzen channel

I don’t think the Knowledge Base says to do that. :slight_smile:

1 Like

No but when that channel agrees with the recomendations in the KB articles I thought it was solid. :slight_smile:

Sorry, but with 770k+ tracks you are firmly in the space where Brian says a “big scary i7 with plenty of RAM and an SSD” are essential. That’s not your father’s NUC.


I run a 270k track setup on an older i7-7700 16g. With ssd nvme drive and it’s fine, on the i7 Nuc it was was ok but struggled a bit under some conditions like multiple endpoints and upsampling. Music library was on a nas bit now on 16tb usb drive.

I have now unplugged the 2 drives and was able to get the remote to load. I have shut off all of the audio analysis and replaced in the 2 drives and it is slowly importing the files. I will update as it goes.


Still no change. The remote won’t come up but the core is churning away. How can I tell if it is still working

H @Ben_Katz,

Are you still able to access the Web UI? Does it show that RoonServer is running and stable?

I have the NUC server connected to a monitor and it says its up and that I can attach to it via the url. I guess thats up

I have now unplugged all the drives again and got the remote to come up i tried playing just tidal tracks and it worked for about 8 songs and then froze and I just ■■■■ it down. I then tried to just load the one drive that has already been loaded. It wouldn’t come up.

Ok it seems like every once in awhile I can get the remote to come up but never with any media attached. I only have about 300K tracks loaded. (Which I cannot play bc they aren’t plugged in) Whats the next step here

Ok. I hope there are people still listening. @dylan @grossmsj, @noris, @Rugby. I got frustrated and loaded the roon remote onto my work laptop. I was able to pull up the remote with the first drive that had already been loaded and the second drive added. I now have the remote up on the laptop with 579,282 tracks. Once I did that I was able to pull the remote up on the remote connected to my stereo.

You use the phrase 'the remote on the laptop with X tracks". To be clear, the drives are plugged into the NUC, right?

Sorry for not being clear. Yes the two drives are connected to the NUC

Glad to hear you are making progress! :grinning:
So, you have your NUC with a library of around 580,000 tracks and two remotes working?
Are you still adding music or working with what you have now?

I haven’t really used it yet and yes I would like to add the other 3 drives but I am not eager to crash it.

I can’t conceive a library that large. Mine is only 4% of that!
If it were me, I’d do it incrementally as well. You have an epically large library that will stretch that equipment, especially as it has to balance importing, audio analysis, database updates, etc. Troubleshooting issues will be less onerous as well.
You should also be aware of what will cause Roon to rescan the library. This isn’t the same as reimporting, but with a library that large it will take resources as well. I’m not sure of the conditions that will initiate a library rescan, but others will.

Scott, I have been collecting music for over 40 years and my partner (musically) was in the music business for 30 years. We have a pretty large collection but it is definitely not the largest.

I tries to plug an another drive and it crashed. I have unplugged all of the drives and have spent the last few hours trying to get the core to come up again. Finally the monitor attached to the NUC said “rcconsole cannot allocate memory” i rebooted again…

Also @grossmsj I have shut off all audio analysis