Cannot get Roon to work as a Roon core with Innuos

Hi Robert

Can you try this, I,ve just done a test on my Windows 10 machine to add a share in Roon

On the folder where the back up is right click on it and select ‘properties’
Select the’Share’ tab, press the ‘share’ button
Select your user name, on the bottom right press the’Share’ button.
this should share the folder.

You should see something that says ’ To change this setting use the network sharing centre.
If you click that link you should see - Turn on network discovery , and Turn on automatic setup of network connected devices are both selected.

If you don’t know the IP of the machine from the search bar search for ‘command prompt’
then type - ipconfig and press return
In the returned text look for - IPv4 Address , which on a standard router will be 192.168.1.XXX

So this is my entry in Roon to add the share , the user name and password are what you use to log into your PC.

Here you can see that windows folder added in Roon
Screenshot 2020-12-21 at 22.51.00

So in theory you should be able to use the above method to add and navigate to your backup folder.

This should cover adding a network share folder that is on the Innuos

Then I think you need to do this but I don’t have one to confirm.

Hi, Thanks for this.

I had done all this already though. But I just went to double check and here is the latest…

OK, what happens if you replace media-server with the IP address of the media server as per my example?

same thing. I tried that earlier on.

This solved the issue…

Are Roon aware of this networking problem? Also, is this a safe thing to do?

I understand that networking issues between devises running different OSs isn’t a Roon issue. However, the error messaging and associated guidance when trying to navigate to a Roon backup for restore could be better? I was on the way down the USB route. I had copied the backup folder to a USB stick, but couldn’t navigate to that either.

This is the only problem with Roon (from a lay user perspective) IMHO. It isn’t obvious that the Roon Core/Server is something that needs careful consideration when setting out to use Roon, particularly how crucial the backups are and moving the Core/switching between Cores, what Roon can run on/what it should be run on etc.

Plus, networking. There needs to be a better way to automate the networking capabilities of the Roon system. Other software doesn’t seem to have all these networking issues.

When I started out, if I know then what I know now I would’ve considered a dedicated server much more carefully.

I am considering moving to a dedicated server at some point in the future. What are Roon’s thoughts on the the M1 Mac Mini?

Spoke too soon. That resolved the issue of navigating to the folder with the backup, but it will not restore.

I also have a copy on a USB thumb drive. How do I go about it now?

Again, I’m not the expert here, but if it was me, I would make a good, clean, new backup from the original core device to a USB drive, then plug that into the new core and do a restore.

Are there instructions for this part. I have resorted to this after failing to successfully navigate the first part of your suggestion.

Hi @Jim_F

Sounds like a very sensible plan to me. Are there instructions anywhere about how to do a restore from a USB drive plugged in to an Innuous.

It’s the same as any restore plug usb drive in set it as backup location via Roons browser it will show up as a mounted disc.

To restore plug it in, goto backups, selecy find backups navigate to the stick in Roons browser it should be mounted as storage if the Innuos is adding it. Restore done.

You need to ensure your keeping the whole structure of the backup and point Roon to the top level of it.

Hi @Robert_Borley,

This should be able to help. You have to do some configuration from

I am just not tech savvy enough to use this product. I habe tried everything. Even the USB backup and restore failed. Formatted USB drive on the Innuos > fresh backup on PC > Roon cant see the backup on the USB stick when pointed back at the Core on the Innuos.

What makes this worse is that Roon was seemingly able to create a backup to the USB drive while it was unplugged.

This is all totally crazy and I am now giving up.

A NUC would have been the easier route, but before you go why don’t you just forget about the backup, connect your local music and services and see how it looks.

1 Like

That sounds like you didnt’t back it up to the USB stick. Not sure why your having so many issues with what is a pretty basic operation. Put USB stick into windows PC. Format it here as exFAT which is Roons recommend filesystem.

In Roon goto back up section. Select Backup Now and then select the USB stick as shown in the images below. These are from phone remote process is the same windows remote will show the drives to the left rather than a drop down box.

Ensure you chose the correct location, back it up, leave it to do its thing when done check the USB stick in Windows to see if it’s made the files. Put it in the Innuos go to Roon Backup, select find backups navigate to the stick the same way as you backed it up to restore. Do not go into the folders it’s created stay at root level of the stick where the backup was chosen to go. Restore, wait and it’s done.

Ha! If only it were that easy!

I did all of that. Didn’t work.

The USB drive (post backing up Roon direct from the PC) just will not show up on the Roon remote’s “Choose folder” dialogue, when pointed back at the Core running on Innuos. On the PC it shows up just fine. It is formatted by the Innuos first, as that is the only way to get it to show up in Roon’s browser. Then plugged into the PC to perform the backup, then back to the Innuos where it can’t be seen. I was up all nigh last night trying all sorts!

Thanks for your pointers though. At least it confirms I am following the correct process. The only thing I would say is that formatting the USB on Windows first, exFAT, means Roon on Innuos won’t see it. Only after formatting on the Innuos can Roon then see it.

To test this I set it as a backup destination on the Innuos Roon Core. I then unplugged it to see if Windows would see the folder it created, which it did. Then I performed a backup on Roon while connected to the Innuos Core without the USB plugged in - literally in my hand and Roon processed the full backup to the phantom USB stick and said it was successful. Crazy.

Sounds like a permission issue of some sort on the Innuos. Are you ejecting the stick from Windows and not just pulling it out as that can lock them up I find.

Does the Innuos OS see the usb stick when it’s put back into it after backing up. If it doesn’t then there lies the problem. Roon can’t fix issues with hardware. The backup restore to stick works fine so this has to be hardware related. I format it on windows to exFAT as recommended. Not sure if innuos supports this if your on later firmware. If it’s not showing up then something is not allowing it to mount. This is not a Roon issue but the operating system of the Innuos. Reach out to them.

I had one last failed attempt via USB (reformatted again on Windows, no joy seeing it on the Innuos Zen Mini Core, then formatting again on the Innuos, before backing up (successfully) from the PC (direct to the USB). Then no joy again on the Innuos restore, even after rebooting it still couldn’t detect the USB drive.

However, my latest, and final attempt, at restoring a backup was back over the ethernet mid morning. (I would never find time for all this at any other time of the year). It worked…finally :sweat_smile:

I have come to the conclusion (only a theory) that any backups I made to folders on the PC that sync with Microsoft OneDrive, do not restore to the Innuos. At one point, I saw a strange error message when copying one such backup to a USB, saying something like “[certain] metadata information [which looked like the sort of thing OneDrive uses to monitor the syncing status of some of the files within the Roon backups] couldn’t be copied”. It errored on files, that for some unknown reason, would not sync to OneDrive cloud servers.

The backups direct to USB failed for different reasons, but a backup to the root user folder (not synced with OneDrive) restored successfully over the network to the Innuos no problem at all. I am yet to see how the Innuos now performs as a core, but the restore was a success.

The solution for me was not to try and restore a backup to a folder synced with Microsoft OneDrive and to make sure SMB1 (whatever that means) is installed and activated on Windows 10, also see this post…

1 Like

Of course you are right about that! I didn’t realise the hassle it would save and it also avoids the wasted (IMO) expense of the Roon Nucleus.

I might get one yet (or use it as an excuse to get a new M1 Mac Mini!).

Will see how the Innuos Zen Mini fairs as a Roon Core


Yes it does.

The problem is the Innuos OS appears to see the USB stick just fine, even after the backup from the Windows PC. It’s just Roon that can’t see it.

I do think this is a Roon issue though. Insofar as it, Roon, is complicated. I mean, when it is set-up and running it is robust and sophisticated. Let’s face it, it is amazing. What it can achieve with all sorts of low end to high end audio equipment, streaming etc. etc. on and on. I went through all this pain because the end product is so damn good.

However, setting up Roon, moving the Core and getting your head around it all is far from straightforward. The error messaging on Roon could be much clearer. Also, I strongly feel that Roon needs to be more prescriptive about the required hardware setup. Once you know, you know and all the info is somewhere (endless support threads, knowledge base etc.). But, one needs a lot of patience, time and help to set it up properly.

The message, if you want to avoid hassle, get a NUC should be shouted more loudly! But when I first discovered Roon, I had absolutely no idea what a NUC was. Thats a whole learning curve itself!