Cannot get Roon to work as a Roon core with Innuos

Core Machine (Operating system/System info/Roon build number)

Innuos Zen Mini, system info and Roon build number attached. The Zen Mini is running innuOS version 1.4.5

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet connection via a couple of Netgear switches to sky Q router and Media PC (where ‘old’ but working Roon server is.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Innuos Zen Mini with RCA out to Class A amplifier. Various other endpoints including Bluesound Node 2i connected to different amplifier.

Using iPhone 12 as remote.

Description Of Issue

I simply wanted to stop using my very old PC as a Roon Core and use my Innuos Zen Mini instead. This is proving extremely complicated. I have no idea how to restore the Roon database backup (backed up to both the PC and the Zen Mini) to the Zen Mini Roon Core. Settings > Backups > Find backups just prompts me to add a Network Share which doesn’t work. Even though the PC can see the Zen Mini as a music store etc. The Roon Core on the pc works just fine with the Zen Mini as an endpoint and storage for all my music files. When using the Zen Mini as a core it only sees a handful of albums and must of my music library seems to be missing even though it is all stored on the Zen Mini. This is all very frustrating and user un-friendly. I love Roon when it works but this kind of stuff just makes me want to give up on it altogether.

1 Like

Have you made sure the backup of the database is accessible over the network? You need to share this so it is. Then follow Roons knowledge base on how to add a network share and restore the database. Or back the database up to a usb stick and stick it in the Innuos and use that.

It’s really not clear what you have done, perhaps try and lay it out in the steps you took.

Core Machine (Operating system/System info/Roon build number)
PC/Windows 10 as Core trying to switch to Innuous Zen Mini as Core
All updates are current.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Home network using ethernet connection with Netgear switches and a domestic Sky Q broadband hub.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Innuous Zen Mini out to Class A amp plus a Bluusound Node 2i also out to another class A amp.

Description Of Issue
Trying to set up Zen Mini as a core as my Windows 10 PC is very slow. Stable and reliable, but too slow and I often want to turn it off because of its location in a spare bedroom.

I have already posted about this problem on this forum. However, there are no willing responders (totally understand).

I am just wondering how to get support from Roon.

It’s not a cheap service and also very difficult to setup. I was just wondering if anyone knows how to contact Roon directly for some support?

Many thanks

Here’s your issue

Way underpowered.

You opened a support thread 3 hours ago. Please keep in mind that today is Sunday and as many other businesses, today Roon support doesn’t work. The ability to set up a music streaming software is not a vital necessity, so please show some patience.

By posting in this Support forum, you will get a response from Roon Support when they get back to work on Monday or soon thereafter.

Thanks for your opinion. Not all that helpful though. Sunday is a day when most of us don’t have to work and have some spare time to attempt to set-up a paid for streaming service like Roon, which is not exactly straightforward. I was just asking how to get hold of Roon support, that’s all. I can’t find a link.

Hi it’s best to avoid cross posting and having multiple topics open, so I’ve them merged to here.

By posting in the Support section of the forum, as you did with your earlier topic…

Roon’s @support will follow this up for you … but most likely this will be after the weekend when then have move staff available.

That said @anon55914447 is quite correct … the device you are attempting to run Roon on is way under the minimum specification.

Thanks. I didn’t realise that this wasn’t just a user forum.

Hi, that’s not my main issue. Roon can’t access a network share that every other device seems to be able to access. Once I am able to restore the Roon database I am hoping that will solve my issue. Most users with this device can use it as a core without any problem (apart from DSP or grouping many endpoints (neither of which I want to do)). I simply want to ditch, my 11-year-old PC, which has no problems running Roon core server either.

Hi @Robert_Borley,

There are a couple of options here — First, you can copy the Roon Backups folder to a USB drive and connect that to the Zen. That would probably be the easiest option.

Alternatively, we can add the location of the backup over the network. Can you share with us what path you’re entering in Roon and what error Roon gives?



I was trying to avoid the USB option because I wouldn’t know how to navigate to and select the backup once the USB drive is plugged into the Zen Mini. Plus it’s another hassle as I don’t have a spare one with enough space and I didn’t know how much space I’d need. However I will buy one tomorrow because it seems like this may be my only option.

In terms of the path I am trying to use, I have been trying variations on:


It just keeps saying “Unexpected Error”, not a helpful message.

My MacBook connects to the Network share no problem. Simply by navigating it shows up. Plus I can navigate to the backup location via the Roon app when the Media-Server PC is selected as the Core.

As you can see, everything nicely mapped and laid out when looking at Roon connected to the Core server on the PC.

It’s just when the Core on the Zen Mini is connected and authorised, its as if the “Media-Server” PC does not exist on the network. Also, Roon doesn’t allow a way of navigating to attached devices on the same network which I don’t find user friendly.

No access to the local network.

I tried to do a new backup via Dropbox, which is nice and easy to add to Roon as a share (shame OneDrive or others aren’t as easy to add because my free DropBox account is limited on space as I pay for other cloud services). However, it failed because of lack of space after taking forever.

I am giving up again for another week. Another failed attempt to switch my Roon Core from my PC, so frustrating when it should be so simple. This is the nightmare side of Roon. Thank goodness using it when it is finally set-up is the polar opposite.

Plus, I am already using the HD on the Innuous Zen Mini as a backup location for the Roon Core server running on my Media-Server PC, so there should already be a copy of the backup on there. I have no idea how to access it through Roon to restore though.

Hi @Robert_Borley,

So the first step here is that we need to make sure the folder you’re trying to access is properly shared on the Media-Server PC. Can you share a screenshot of the share settings for that folder? We have information about that here in our Help Center:


Here it is. My MacBook can see it ok. I just copied this screenshot over to my MacBook from the PC using the network share.

I am also trying to upload the latest Roon backup folder from my mac to Dropbox in an attempt to get Roon to see it from the Zen Mini that way.

Also, I am backing up the Roon DB to the Zen Mini from the PC so there should be a copy already on that drive. This is all so confusing.

Here’s what is being returned by Roon when the Innuos Zen Mini mk3 is selected as the Core and I try to find the backup over the network…

I’ve tried all manor of things, IP address followed by device name, network share, no device name etc. etc.

This is what it looks like from my MacBook… Looks fine to me. :face_with_symbols_over_mouth:

I’ve just cleared out some space in my old “free” Dropbox account because thats all the Zen Mini can see. Weird because everything else on the network can see the Zen Mini. It’s taking forever to upload the backup to Dropbox and I suspect forever to restore it from there (if it works). :crossed_fingers:

Roon managed to navigate to the Dropbox Folder with the uploaded backup. This is what I keep getting when trying to restore…

I gain 1% each time I select retry…

So painful.

How would I point it to the backup already on the ZenMini or a USB stick with a copy of the backup folder?

Hi Robert

Can you try this, I,ve just done a test on my Windows 10 machine to add a share in Roon

On the folder where the back up is right click on it and select ‘properties’
Select the’Share’ tab, press the ‘share’ button
Select your user name, on the bottom right press the’Share’ button.
this should share the folder.

You should see something that says ’ To change this setting use the network sharing centre.
If you click that link you should see - Turn on network discovery , and Turn on automatic setup of network connected devices are both selected.

If you don’t know the IP of the machine from the search bar search for ‘command prompt’
then type - ipconfig and press return
In the returned text look for - IPv4 Address , which on a standard router will be 192.168.1.XXX

So this is my entry in Roon to add the share , the user name and password are what you use to log into your PC.

Here you can see that windows folder added in Roon
Screenshot 2020-12-21 at 22.51.00

So in theory you should be able to use the above method to add and navigate to your backup folder.

This should cover adding a network share folder that is on the Innuos

Then I think you need to do this but I don’t have one to confirm.

Hi, Thanks for this.

I had done all this already though. But I just went to double check and here is the latest…