Cannot get SOTM SMS 200 ultra connected to roon

I have roon core installed on my windows 10 PC and trying to use a SOTM 200 ultra streamer. I have it connected to my Hitron router/modem via a cat 7 ethernet cable. But when I go into my router control panel to see what the IP Address assigned to SOTM. It doesn’t show up and whether I connect the sotm or not, it shows only 4 devices connected via ethernet to my pc (which is also connected to the router via ethernet).

The SOTM is powered on and I tried restarting it, my pc and my router. I tried simply writing http://eunhasu/ but that didn’t work.

Any idea what the problem is? Thanks.

Hello @Wanderer46,

Are the lights surrounding the ethernet port on the sMS-200 Ultra lightning up? That would be the first thing I would look for. Second, I would make sure that the microSD card is seated correctly, please make sure to unplug the unit before checking this.


Sounds like the OS might be corrupted. I’ve had the same problem.

You can download a new copy from here -

the green left light blinks, yellow light doesnt

Slim I think you might be right. When I put the microusb in my pc it says cannot read and tells me to format right away. I format and now it shows the microSD as 3 different usb drives of different sizes on my pc.

After the fresh OS write to the usb I got into Eunhasu! Thanks so much guys, esp Slim

1 Like

This happens to a healty card also so this dont tell you that the card is corrupted.

My 200 Ultra have done this twice and the first time the card was damaged beond repair. Now I have two cards so when upgrading to a new firmware like 4.5 last week I have a working copy of 4.22 on the other one.

Always a great idea to have a working backup.

Try this link.
Helps for me