Cannot launch Roon on my iMac

Core Machine (Operating system/System info/Roon build number)

Roon is latest build, downloaded last night.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Just the Mac over WiFi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
None, doesn’t matter if I have any output devices connected.

Description Of Issue

For a few weeks, I cannot launch the app at all: it just sits there with the black quote screen, and I eventually get the dreaded “application not responding” message and have to force quit. I just updated Roon yesterday, and have restarted the machine multiple times.
Thanks for any help!

Could it be an open gl 3.0 issue…maybe google if that way old Mac has hardware support…in latest release update there were addition features added that required additional use of some previously unused open gl 3 features.

Hi @Chris_Berens,

If you reinstall the Roon application is there any change?

Looking at the graphics card being used here — I’m not seeing any confirmation that this card supports Open GL 3.0 which is a requirement for Roon as wizardofoz mentioned. If this device does not support OpenGL 3.0 that is likely why you’re experiencing this issue.

Thanks all. Tried the suggestions and no change.

Is there a legacy version of Roon I can install?
Don’t care too much about new features and would rather not throw out the baby with the bathwater, just because it’s old…
If not, I’ll have to go the server route and control with my “way old” iPhone 6S. (Hopefully that still works!)

Try the roon server option with control from iOS devices but note that a phone doesn’t allow full access to all settings and options due to display size. I think iOS requires to be at v11 or better, don’t have any 6S left to try.

Hi @Chris_Berens,

I spoke with the team about this and they’ve confirmed that your device should meet our OpenGL requirements, so that is likely not the issue here.

Would you kindly use the directions found here and send us over a set of logs using a shared Dropbox link?


Thanks Dylan. Logs are here:

For the record, I’m able to use the server method and control via my iPhone. Of course I’d much prefer to use the actual computer!

Please let me know if I can provide any additional info.

Thanks, @Chris_Berens! I’ll get these over to the team.

Please note that due to the holiday the queue for the technical team is a bit slower than typical, so apologies in advance for any delay. I’ll be sure to reach out soon once I have their feedback.

1 Like

No worries, I am patient. Happy Holidays to the Roon team!

Hi, since few days I’ve the same problem. Roon does not start at all on my MacBook Pro wit MacOS Catalina version 10.15.2.

Hi @Chris_Berens,

I spoke with the team about their evaluation of the logs you sent over. Unfortunately, there isn’t much to go on there since the crash is happening pretty early — Sometimes there are traces that explain things in similar situations, but that doesn’t appear to be the case here. There are system-level logs we can gather which can explain things a bit more, but first I’m hoping to verify a couple of other things.

  • Can you confirm that you have backups of Roon from before this started occurring?
  • Where is your library stored? An internal drive? USB drive? NAS?
  • Do you have any USB audio devices connected? If you disconnect them is there any change?

Thanks Dylan…

  • I should have a backup via Time Machine. The last backup was October 4th.
  • The library is on the internal HD.
  • It doesn’t matter if I have any USB devices connected or not, I see the same behavior.

On another topic: I’ve been having trouble streaming through Roon for months (Tidal and Qobuz). Should I start a new topic about that issue, or can I share details here?

Time machine is not recommended to back up roon and it’s data. You should use a roon run backup from the settings menu to local and external disks…more than one location is highly recommended.

I also have Roon data backups on the same disk as the TM backup. I didn’t think the app itself was backed up that way.

Hi @Chris_Berens,

Thanks for confirming you have backups of your Roon database and for the additional info. I would like to try a troubleshooting step here to see if it helps, and this involves setting the old database aside and starting with a new one as a test. Please use these instructions to do so:

  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder
  • Verify if the fresh database works as epected
  • Restore the database from the backup you have

This is correct, as mentioned in our Backups Documentation we strongly suggest against using “Live Snapshots” of your Roon database, as we have often found that restoring live snapshots cause integrity issues. If you have Roon-created backups these would be the best to use when restoring.

Let’s see if refreshing Roon with the above instructions helps with this issue as well, if the issue is still the same afterwards, we can open a new support topic on this behavior. Thanks!

Noris, you saved me!
The Library is loading up, and Tidal and Qobuz are streaming again.
Many, many thanks!

1 Like

Hi @Chris_Berens,

Happy to help! If there’s anything else you require assistance with (including the dropout issue), please feel free to open a new thread with the details and we can take a look. Take care!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.