Cannot log back into TIDAL on Roon

hi, I just started having the same problems, no tidal song could be played, too many errors. I tried a few things, first, tried to log out, so I could try to log in afterwards to no avail. Tried to log in and, I was not able to. My tidal account works fine on every other device I use it, the only place where I`m not able to sign in is in Roon. I also tried a recommendation I found on one of the threads on #support. My core is on a mac. in the library folder, i reached to roon, looked for the cache folder and then moved it to my desktop. I then made a reboot of the core machine, started roon again, tried to log in again, and nothing. Most of the use I give to roon is to run Tidal through my hi-fi, my physical file library is quite small, so this is a must have for me in order to use the service.
please advise on what to to to fix the issue.

Hi @Arturo_Saucedo,

I have split your post into it’s own thread so that I can better assist you here.

Can you confirm that the same TIDAL credentials work properly on the TIDAL web player (

What is your network setup like? Can you please list the model/manufacturer of all your networking gear?

A post was split to a new topic: Have to restart Macbook to use TIDAL

Hi @noris, thanks for your reply, have not been able to use my hi fi yet, since I have not been able to sign in yet.
I use the same credentials to sign in on (the web page), but i cannot sign in through roon. “BAD USER NAME OR PASSWORD” using the same credentials. like I said before, Tidal works just fine on every other device I use it.
I wonder how can this be a network issue since I had been using my hi fi for months without any hassle. but anyway my wifi router is a Nokia model G-240W-G from 2019, is a dual band wifi modem. I then go from there through a wired ethernet connection to my core which is an iMac, I have another ethernet connection with a CAT6 cable to a SMS-200 audio computer.
Hope this helps… though it looks more like an issue between Roon and Tidal software wise, I can play tunes from my library, mostly DSD files, the only thing not working is TIDAL, but as I stated before, I rely heavily on it for playback on my hi fi. therefore, is basically lifeless now. Please help.

1 Like

Hi @Arturo_Saucedo,

Thank you for letting me know that additional information! Also, apologies for the delay in getting back to you due to the weekend.

I have gone ahead and activated diagnostics mode for your Core and what this action does is automatically upload a log-set to our servers.

I see here that you are running on an outdated version of Roon, looks like you’re a few versions behind and due to recent TIDAL security changes, you’ll need the new version of Roon to be able to login.

Please navigate to Roon Settings -> About and click the install button to install the latest build of Roon.

If you cannot automatically update for whatever reason, you can also create a Backup of your Roon database and then manually install the latest Roon build from our Downloads Page.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.