Cannot log-in to my Roon account

Roon Core Machine

Intel NUK 10 Intel Core i3 Processor
SK hynix Gold P31 500GB PCIe NVMe Gen3 M.2 2280 Internal SSD
Crucial 8GB Single DDR4 2400

Networking Gear & Setup Details

Roon Core hardwired to the internet via Ethernet to Xfinity Wifi Modem

Network Properties:
Protocol: Wi-Fi 5 (802.11ac)
Security type: WPA2-Personal
Network band: 5 GHz
Network channel: 157
Link speed (Receive/Transmit): 585/585 (Mbps)
IPv6 address: 2601:647:5500:8310::5864
Link-local IPv6 address: fe80::acaf:f3cf:c459:fd5c%11
IPv6 DNS servers: 2001:558:feed::1
IPv4 address:
IPv4 DNS servers:
Manufacturer: Intel Corporation
Description: Intel(R) Wireless-AC 9560 160MHz
Driver version:

Roon is up-to-date. The latest version is installed last week.

Connected Audio Devices

miniDSP SHD Studio > DAC > pre-amp > amplifier > speakers
Bluesound Node 2 > integrated amplifier
Schiit Modi 3 to Magni to headphones
Apple Home Pod Mini

Number of Tracks in Library

Mainly in Tidal library (c. 150,000 tracks)
Music on flash drive about 200 GB. (currently 399 albums)
No NAS, 2 Samsung USB Flash Drives (128 GB x2) inserted to NUK.

Description of Issue

I cannot log in to my Roon account. After I attempted to restore one of my backups, Roon doesn’t let me log-in. Checked the internet connection but it has no problem. (see the first screen shot)

I also tried to log in with a different core - my laptop (running Windows) but receive this screen. I cannot unauthorized the ROCK. The “Unauthorize” button is not responding. Please help!

I had a clean installation on my NUK but the same problem persists.
I think the problem is with my user account, it’s not on hardware or software.

Sorry, ignore the above. I tried to delete it but the forum software won’t let me do it until 5 hours elapses, for some reason.

1 Like

Roon, please, help is needed.

Did you click the “Go back” button at top left of the screen?

Yes, I did. The endless loop and this screen below - the dead end without “go back arrow” but you can click “Help Centre” which directs to the blank page.

I follow this troubleshooting method and fixed the problem:
“There was an issue loading your database”


  • Stop RoonServer from running in ROCK’s WebUI

  • Navigate to your ROCK’s Database Location

  • Find the folder that says “RoonServer”

  • Rename the “RoonServer” folder to “RoonServer_old”

  • Restart the RoonServer in the WebUI to generate a new Roon database folder

  • On the Roon Remotes, press “Use another Core” and connect to the new database

  • Restore a backup

1 Like

I still don’t know why this connection problem had occurred though now everything works fine.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.