Cannot log in to my TIDAL Account

Asrock Bee n3000 NUC

  • Intel® N3000 Processor (Up to 2.08 GHz)
  • Microsoft® Windows® 10 64-bit
  • Intel® N3000 SoC
  • 8GB DDR3L-1600MHz
  • Realtek ALC283
  • Gigabit LAN
  • 500GB mSATA SSD
  • 802.11ac + BT 4.0
    Front I/O
  • 1 x USB 3.1 Gen1
  • 1 x USB 3.1 Gen1 (Type C)
  • 1 x IR
  • 1 x Audio-out with MIC-In
    Rear I/O
  • 2 x HDMI*
  • 1 x DP*
  • 2 x USB 3.1 Gen1
  • 1 x LAN

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Asus dual band Gigabit router
The Asrock is connected to the router via a cat 7 audioquest cable

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Arcam rDac via USB to the Asrock
Chord Mojo with Poly via wifi

Description Of Issue

I cannot connect to my tidal account with Roon for a week. I type the account name and password, it takes a long time and it says wrong password at the end.
I checked the user name and password with tidal apps and online directly and they work. I tried to reenter everything many times so I am sure I am not making a spelling mistake etc.
Please help me to use tidal with roon again. It had been working fine for nearly a year now until this strange problem occured.

And internet radio is working fine so it is not an internet connection problem.
Internet is also working fine on the Asrock directly when I use the browser. Wifi also works fine with everything.

Hi @Jozsef_Scheiling,

Since experiencing this issue have you tried rebooting your Core machine? Often times that will resolve this type of issue. Please give this a try and let us know if it helps — Thanks!

I tried to reboot several times. It did not help.

Hi @Jozsef_Scheiling — Thanks for giving that a try.

Next, let’s try clearing your cache:

  • Close Roon on the Core machine
  • Find and open your Roon database
  • Navigate to Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

Hi @dylan
I did as you advised. The proble persists. It says bad username or password while I know for sure I am using the right ones.

Hi @Jozsef_Scheiling,

I sent you a PM with next steps.

Hi @Jozsef_Scheiling,

As discussed via PM, we confirmed that everything seems okay with the account, so moving forward I’d like to focus in on the current networking setup.

We’ve found in the past that Google DNS can help with TIDAL networking trouble. Can you give Google DNS a try and let us know if that helps?

Hi Dylan,
The final solution was to uninstall roon with all settings and backups then reinstall it. How I can log into tidal with no problem.
Before when I left the settings and backups untouched during reinstalling, tidal did not work. So probably there was some setting messed up. Only God nows, or maybe you.

Hi @Jozsef_Scheiling,

I’m glad that things are working for you now! Please feel free to reach out if you ever have any other questions or issues. Happy listening :headphones:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.