Cannot log into Tidal

I am running version 1.5 64 bit D
Mac OS Hi Sierra 10.13.5 on Macbook Pro but Roon Server is Sonictranporter (Linix)
Music Stored on a Microrendu USB interface about 200 CDs stored.
My Tidal account is from USA
Its a HiFi (lossless account)

As I stated in prior email, I suddenly could not get Tidal to play via Roon after having it work seamlessly for months. I read in a support string that other users had fixed this issue by clearing Roon Cashe. I did this but now I cannot log back in to Tidal via Roon. I can log into Tidal directly and I can play me stored music so system is fine but I just cannot integrate Tidal with Roon after clearingf cashe. Please help.

Hey @Kenneth_Brown — Thanks for sharing your report with us!

Can you confirm what message you are receiving when you try to login? Please also see troubleshooting steps below that often help with this type of issue:

  • Oftentimes a simple reboot to the Core machine will resolve this issue and allow you to login when Roon is restarted.
  • Close Roon, find your Roon database and delete the tidal_account file (Database > Registry > Core > tidal_account). Once you do this try to login again.
  • Check that your account is still active, as suggested here. In the past we have seen that you may be able to login to the TIDAL account in the TIDAL app, but the subscription itself may not be active therefore cannot connect to Roon.

Let me know if these steps help!


The message I get is “ logging in”. But the message just stays on my screen.
How do I get into Roon Data Base?

Thanks for the info, @Kenneth_Brown!

  • Open Finder and click Go in the top bar
  • Hold down the Alt key to unhide the Library folder
  • Click the Library folder
  • You should see your Roon folder here
  • Inside the Roon folder is the Database folder


My Roon Core device is a Sonic Transporter which I believe runs Linix. I can control Roon with my IPad or MacBook Pro. Would my Roon data base be on my laptop or on the Sonic Transportor?

My apologies, @Kenneth_Brown!

Yes, your database will be on the Sonic Transporter. You’ll need to access the Transporter over the network from the remote device. The path for RoonServer on the Transporter should be /var/roon/RoonServer.


The Sonic Transporter folks told me the Roon database would be on my “Controller” which is MacBook Pro. I was able to find the Tidal Account File in Roon data base on MacBook and delete it but I still cannot log into Tidal via Roon. When I go to services, it says “Tidal Not Configured” and gives me the option to either create a Tidal account or to log in if I already have an account. Since I already have an active Tidal account, I try and log in. When I do, I get the Tidal symbol and an indication of “Logging In” which never completes. Please help!

Hey @Kenneth_Brown,

Just to clarify — You can access your Core machine from the Remote device, but the Core / Database itself will be located on the actual Core machine. So, if you are using the Sonic Transporter as your Core, you’ll need to access the Sonic Transporter’s files over the network on the MacBook.

The Mac will also have a Roon folder, but since it is not your Core machine, clearing the cache here will not have the effect we are looking for. It sounds like you may have cleared the cache from the Roon folder on the Mac, but if you’re unsure, please share a screenshot of the folder in Finder so we can know for sure.

Apple has some instructions that explain how to connect to a folder over the network so you can modify the files. You’ll want to connect to the Sonic Transporter and try removing the cache again and then restart Roon and try again. You can read more about where the database would be housed in our guide here.


I have gone into Sonic Transporter over the network and cleared the cache. I also cleared cache from Roon folder on Mac and deleted Tidal folder from Roon/Settings on Mac but can put both back if I need to as I can move them from “Trash”. Should I move them back from Trash? Still unable to log into Tidal via Roon.

I tried both ways after clearing cache on Sonic Transporter. That is with Tidal folder moved back to Roon/Settings on Mac and without it there. Also tried removing Tidal cache folders from Roon cache on Mac and putting them back. I tried logging on to Tidal in all combinations. Also tried changing my Tidal password on Tidal and reentering when trying to log on through Roon. Nothing works. I will be working from home tomorrow and need to get this resolved. Can someone please give me a call at [personal information removed by support] so we can address this issue in real time?

Hey @Kenneth_Brown,

Just to confirm here before moving forward:

  • Have you tried rebooting your Sonic Transporter since you started having these difficulties?
  • Did you delete the Database/Registry/Core/tidal_account file from your Sonic Transporter (not Mac)?

No, you do not need to move these files back.

In some cases we have seen instances of this happening where the TIDAL account is active, but the TIDAL subscription is not. May I ask that you please login to your account on the TIDAL website and navigate to the Subscription section. From there you should see 2 boxes, one for a HiFi subscription and one for a standard subscription. Can you confirm that there is a green checkbox in one of these boxes indicating that there is an active subscription? See screenshot below:



Yes I have rebooted SonicTransporter.
Yes I have checked my Tidal HiFi subscription and the box is checked.
No I have not deleted the Database/Registry/Core/ Tidal account file from my Sonic Transporter as I do not know how to access that. Can you help me figure that out?

Thanks for confirming, @Kenneth_Brown.

You’ll need to access your database on the Transporter from the Mac. The first step here is to make sure we can access your Transporter over the network from the Mac. You mentioned that you cleared the cache on the Sonic Transporter - you were able to connect to the Transporter’s files over the network from the Mac to do this, correct?

The instructions linked to above have some great details, but you’ll want to connect to the Transporter from the Mac using Finder and connecting with SMB like this:

smb://[COMPUTER NAME]/[Folder Name] (example - smb://sonictransporter)
smb://[IP Address]/[Folder Name] (example - smb://

Once you are connected you should be able to find your Roon database and follow this path Database/Registry/Core/tidal_account.


I tried and am unable to access. I need some real time help with this please. Can someone call me at [personal information removed by support]?

Sincere apologies for the difficulties here, @Kenneth_Brown.

We do 100% of our support via the support forums, and while we sometimes hear from people wondering about phone support, email support, or other more traditional methods, we almost always win them over by resolving problems here every day. I can tell you that we stand behind our products and our support 100%.

Since you’re unable to connect to the Sonic Transporter over the networking using smb, I’d like to point you to this article from our knowledge base regarding the Sonic Transporter. Specifically:

Everything on the sonicTransporter can be reached from the web interface. If you go to you will see a link the web interface of units running on your network.

You click manage next to the IP address of the unit you want to administrator it will redirect you to the IP address of that unit.

Click on Settings -> Roon Server

This will give you a checkbox for Expose Roon Database to the file share. Once this is enabled the Roon database will be exposed as a samba file share. You can copy/delete/modify etc from a computer on the local network.

Can you try accessing the Sonic Transporter using this method and let me know if you have any success?


1 Like

paging @agillis

As I mentioned in a prior email, I have accessed the Sonic Transporter from the web interface and cleared the cache and enabled the “Expose Roon Database” to the flle share. I don’t know what to do after that and will need step by step and explicit instructions please.

Thanks for the clarification, @Kenneth_Brown.

Here’s what I would like to do try next:

  • Reproduce the behavior (try logging in to TIDAL)
  • Note the time that you attempt this
  • Report the time back to me

Once I have the timestamp from your attempt I will enable diagnostics on your account and pass the diagnostics report over to the technical team for analysis. They can review the report in relation to the timestamp provided and gain some insight into why you may be experiencing this issue.


12:17 Pacific

Thanks @Kenneth_Brown!

I’ve enabled diagnostics on your account. I’ll keep an eye on our servers and pass the report along to our technical team once they’re in. I’ll be sure to update you once I get feedback from them.