Cannot login to Roon, getting network error after update 2.0

Roon Core Machine

A4 processor, 16GB, 128GB SDD, 1 TB HD

Networking Gear & Setup Details

Temporary setup Huawei 4G router , direct ethernet connection router

Connected Audio Devices

Pi3 with Rooopie,
Various Chromecast devices
Sonos play 5

Number of Tracks in Library

I can’t remember 1500 cd’s or so

Description of Issue

Some months ago when Roon ARC came out I installed it on my mobile phone, it then requested me to update. Updated server to 2.0 build 1128
After that I tried Arc, it worked.

Since then our fibre connection has been out of service since 2 months.
I tried recently to get some music running again, but was asked to login and received network error.
When I clicked to change my password, I also received a network error.

Today I tried it again, connected all equipment directly to the 4g router that I use at the moment. Checked internetconnection and dns.
However I still get the login request and the connection error when trying to access my server.
This is rather frustrating, how to solve this issue?

I have been without music for 2 months now, so it is getting urgent.

Thanks in advance,


Am I understanding correctly that this is only with ARC? Your regular Roon works?

If yes:

  • Does ARC work / can you log in if your phone is logged into your local wifi?
  • Is there any error shown in Settings > Roon ARC within the main Roon app?

Thanks for your message, I have tried on a local network.
To no avail
No, Roon does not work nor ARC :frowning:
Roon does not let me login, gives me a red internet connection issue warning
Arc gives me poor connection notice and only plays songs that were previously downloaded

Thanks, this narrows it down somewhat. So essentially you can’t login to your Roon core at all, neither with the main remote nor with ARC, and apparently because the Core does not find an internet connection. All the rest are just follow-up errors.

As your core is on an Ubuntu machine, are you using this machine for other things as well, and is it otherwise able to use internet normally?

As I am temporarily using a 4g connection, before on the fibre modem I had no issues.
I have no issue connecting to the internet with the 4g router, I can ping my roon server, the roon server is discovered by roon, but I need to login with username and password and then I receive a red warning that there is an internet connection error.

The ubuntu server is only used for roon.
I have not hooked up a monitor and mouse to my ubuntu server to check if it can connect to the internet. I presume it is ok as I can ping the server.

It is certainly significant that this only seems to happen when you try to log in.

If you can ping the server from your local network does not necessarily prove that the server can access the internet.

If you are running the server headless, how do you administrate it? Can’t you log into it by ssh or something? (Without attaching a monitor and keyboard to it)

That service is probably CGNAT and you won’t be able to setup ARC directly as it needs a public facing IP. You might try calling your carrier and see if you can get that.

Hi @Hjalmar_Dijkstra ,

Sorry to hear about the issue here. Can we kindly as that you access your Roon logs using these instructions and upload a set for review to the below link and let us know once uploaded? Thanks!

Hello All,

thank you for your support.
I found the error was caused by a crappy Huawei 4G router.
After replacing the router all is musical and well :slight_smile:

I was presently surprised when I hooked up a Sonon Play 5 Gen1. As Sonos does not support it any more I was thrilled to hear it work very well as a roon speaker :star_struck:


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.