Cannot login to the Tidal service anymore from within Roon

The access to Tidal titles from Roon stopped sometime ago (most probably since yesterday or the day before). I then logged out and wanted to login again into Tidal. However this is no longer possible. After entering Username and Password, it takes some time (more than a minute) until an error message appears: “Network error: Please check your connection”. This is the case from an iPad and a Mac as Roon endpoints. A restart of the Roon core (Nucleus) did not solve the problem. From the web and from the Tidal app (iPad) I can login with the same Username/Password into Tidal without problems. The access to Qobuz is still possible (there I can logout/login from Roon without problems).
Any suggestions?

Hi @Rene_Oskar_Kuehne,

Often times a reboot of the Core machine will resolve this type of issue — Can you give this a try and let us know if it helps?

Hi Dylan. Thank you. Now I did a full reboot of the Nucleus (in the past, I just did a restart of the Roon server software). However the problem is not solved.

Thanks for confirming, @Rene_Oskar_Kuehne.

There are a couple of areas that this issue might be stemming from then. First, I’d like to verify that the TIDAL account is in good standing. In the past we’ve seen that an account issue caused the subscription to lapse, and while you can still log in to the app on TIDAL directly, the subscription isn’t active. If this is the case you cannot log in to TIDAL in Roon at all.

You can verify this by going to the TIDAL site and going to the Subscription settings. You can verify if your account is active if you see a checkmark like in the screenshot below:

Hi Dylan

The account seems to be ok: see below.



Hi @dylan
Any news?

Thanks for confirming that, @Rene_Oskar_Kuehne!

Next, let’s try clearing the TIDAL cache. Please see the following steps:

Let us know if this helps!

Hi @dylan
I have found:
Within folder “Cache” there are 8 folders and 2 files. Among the folders there are “tidal” and “tidal_2.db”.
Do I have to move everything which is now inside “Cache” or just what is in those folders with tidal in the name?

Hi @Rene_Oskar_Kuehne,

You can move everything within the Cache folder which will clear everything just to be safe. Once you start RoonServer back up again the cache will re-generate with fresh data.

Hi @dylan

I have done all as suggested. The issue has not been solved.
After pressing the Login button it took approx. 100 seconds until the error message is displayed:

Hi @Rene_Oskar_Kuehne,

To recap, we’ve tried:

  • Rebooting the Core
  • Confirming the account is active
  • Clearing the cache

Since we’ve done this, there are two likely possibilities that are occurring:

  1. There is an issue with this specific TIDAL account’s ability to log in via Roon
  2. There is a networking issue blocking the Nucleus’ connection to the servers

1 is less likely since we’ve confirmed the account status has a good subscription, so I’d like to focus in on #2. Can you describe your networking setup? If you reboot your router is there any change?

Hi @dylan

My network setup (relevant parts only):

Network topology (1 GBit/s network, wired with glass fibre or copper):

Provider — R — S1 — S2 — S3 — NucleusPlus

R: Router, Asus RT-AC5300, OS: Asuswrt-Merlin, Firmware version 384.5,
acting as network access router, wired with glass fibre to the provider (1 GBit/s), WLAN network access point

S1: Switch, Cisco SG350-10P 10-Port Gigabit PoE Managed Switch, Firmware version,
acting as DHCP-Server for the local area network

S2: Switch, Cisco SG350-10P 10-Port Gigabit PoE Managed Switch, Firmware version

S3: Switch, Aqvox SE

As suggested by you, I have rebooted the router (“R”). Afterwards the login to Tidal from Roon could be performed successfully again. Thus the issue has been solved by the reboot of the router.

Nevertheless I cannot understand the “behavior”, since none of the network devices have been changed/rebooted after the last successful login and before the start of the problem. The login problems did occur on endpoints on the WLAN as well as on a Mac connected directly to a switch. In addition the login procedure to Qobuz from Roon through the same router worked all the time. However, unfortunately it will not be possible to find the detailed roots of the problem.

Thank you for your support and kind regards,

1 Like

Hi @Rene_Oskar_Kuehne,

I’m glad that things are working for you now! Please feel free to reach out if you ever have any other questions or issues. Happy listening :headphones:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.