Cannot login to Tidal in Roon

Core Machine (Operating system/System info/Roon build number)

PC/ Windows 10/ i7 3770

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet, Netgear router/modem

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

JDS Labs Atom amp/DAC

Description Of Issue

Cannot login to Tidal, 502 server error. Internet is working fine. Reset roon, and core, still not working. Tidal works fine on my phone.

1 Like

I am experiencing exactly the same issue.

Tidal works OK on my Mac, but out of the blue I got the TIDAL service disconnected from Roon (I was using it 2 hour ago) and now I cannot login to Tidal from Roon - I get to a page where I need to input my Tidal credentials and then I get the 502 error in the web page.

Core Machine (Operating system/System info/Roon build number)
macOS Catalina, 10.15.4 / Core i5 | Roon v1.7 (build 528) stable

I also get the 502 error. Roon v1.7 MS Surface Book 2 15".

Same here. It seems to happen everywhere. Roon has been attacked by Corona

Same here 502 error

Error: Server Error

The server encountered a temporary error and could not complete your request.

Please try again in 30 seconds.

All you out there. Keep the :mask: on

Can’t login either on Roon,but can get into Tidal direct

Me as well I cannot sign into Tidal I have an error message server can not connect under account it reads trying to log in
I agree Roon hit by Corona🙃

I’ve got the same issue. Tidal app works fine, but cannot login to Tidal through Roon and thus no Tidal content. I’m also seeing the 502 errors when Roon tries to connect.

+1. Literally just renewed my Roon sub after taking a hiatus to evaluate other apps, and I’m unable to login via Tidal due to a 502 error from :\

Edit: Looks to be working now. Kudos to the Roon team for resolving in a timely manner.

Same here!

Try now. Mine just worked after failing for about an hour.

Working now for me too.

All good for me thankyou to the communities one big happy Roon family

Working now!

Hi All,

Thanks for the reports and glad to hear that the issue resolved itself. It sounds like it could have been a temporary issue with TIDAL’s login servers that has since been resolved. If you have further issues logging in please open up a new support thread, thanks!

I can also confirm that its is working fine again!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.