Cannot longer find my NUC/Rock PC on my network [Solved]

Here is from my Roon desktop on my pc:

I think this is very mysterious. Is there something wrong with my PC, or is ist the NUC/Rock that causes the problem?


Hey Peter,

We’re looking into this, and we have an understanding of the underlying issue. We recently enabled SMB2 on ROCK, but I think Windows may be blocking “guest” access (as described here). This is probably something we will need to fix, so I don’t think this is related to your setup.

For now, try this workaround: Go to Control Panel > Programs and Features > Turn Windows Features on or off > confirm the the box for “SMB 1.0/CIFS File Sharing Support” is checked.

Let us know how that goes. Thanks!

I have enabled this - same result.

Hey @Peter_Leinslie, with Fall Creators Update MSFT introduced a lot of changes to network. One of those change was disabling Guest access on Win 10 Enterprise and Education. Since you use Enterprise and ROCK uses Guest access by default this might be your issue. You need to manually enable Guest access on your Win machine:

  1. Press Win + Q
  2. Type edit group policy and hit Enter
  3. Go to Computer configuration\administrative templates\network\Lanman Workstation
  4. Open Enable insecure guest logons
  5. Set radio button to Enabled
  6. Press Apply
  7. Press OK
  8. Reboot Win machine
  9. Try to open ROCK folder once more
1 Like

It works!
Thank you very mutch!

3 posts were split to a new topic: Can’t connect to NUC running ROCK on network after Windows update