Cannot open the application

HP laptop as core running windows 10

BT Router

Logitech Squeezebox as endpoint

Problem: Accepted update. Now, when app opens, it stops responding. Have deleted and reloaded software but same problem.

Try updating the graphics driver in the laptop.

I have checked for updates. I was able to update to Windows 10 version 1909, but no option to specifically update the graphics driver.
Roon starts. And now it finds the squeezebox………but then the circle starts spinning and the (not responding) status is shown.

I have tried to reinstall again.
The 64 bit version gives an error (not for this PC). The 32 bit version starts, bit back to “not responding”.
The 64 bit version worked before the update (the Roon update).

Hi @Michael_Brooks,

Can you provide some details on the laptop? What are the specs? What GPU does it use? Does it support Open GL 3.0?

Its an Intel Atom Z3736F@1.33ghZ.
a 32 bit OS x64 processor.
I am sorry, I don’t know what Open GL 3.0 is or how to find out if I can support it.
Roon worked fine on this PC until I updated last week.

So I Googled it. My graphics card is an Intel ® HD.
Total memory 1021 MB
32 MB display.
Hope that helps.

The newest available Graphics Driver is very recent and can be found here:

That fixed it. Thanks guys.
Got a blue screen of death halfway thru the driver install…….but it sorted itself out when I restarted.
I am a PC basic user, so I really appreciate your support.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.