Cannot play tracks from Tidal (Tidal sync works, internet radio works)

Roon Core Machine

Windows 10 Home, v 21H2
Intel i7-7700K CPU @ 4.20GHz

Networking Gear & Setup Details

Gigabit fiber, Araknis gigabit router & switches, Cat6 core & remotes

Connected Audio Devices

Naim ND5 XS 2 streamer
Apple TV streamers
Chromecast Video
all on Cat6 connections

Number of Tracks in Library

16780 tracks

Description of Issue

All Tidal tracks fail to play back: After clicking the play button, the time shows:0:00 and doesn’t move, and the elapsed time “bar” shows a waiting state (moving back and forth).

This occurs no matter the playback device - Naim streamer or AppleTV.
Restarting the Roon Core windows server did not resolve the issue.

Everything else is working:

  • internet radio & local file playback
  • browsing Tidal albums, art, and tracks
  • Tidal playback using my account on any other non-Roon device or platform
  • signing in to account on

Was working fine a few days ago. My Roon core recently updated to build 970 - not sure I can tell, but the problem may have occurred with the update.


I have the Roon Server logs from before and after the reboot - not sure if I can attach them here, so I uploaded them under my name to the Logs Uploads Server.

Thanks, please help asap…

Monty Kosma

suggest you remove or sanitize the image with your email in plain sight

maybe try turning off windows firewall if its on…see if that changes anything - or any other firewall you might have in play for that matter


Not sure why that would have changed when it worked fine last week, but I tried disabling windows firewall entirely - no effect. Nor does any traffic appear to be blocked by my pi-hole DNS server.


And if you bypass Pihole?

1 Like

Still fails with windows firewall and Pi-Hole disabled.

Have you restarted everything including the router after disabling the firewalls and pihole? What dns is it using in this setup with everything out play?

Hopefully Roon @support can help, I’ve sent them the logs and debug is turned on…

@wizardofoz DNS is not the issue; it makes no difference using Cloudflare ( As I said, this was working fine about a week ago and I’ve made no changes to network or anything else around here.

FYI - got it working. No explanation as to what happened. I remembered that I’d reported a similar problem in April 2021; back then, Roon support said they were “investigating” why many people were having issues with Tidal and suggested deleting my tidal_account file.

Specifically, what fixed my issue was the following steps:

  1. delete the file tidal_account from the Roon Server\Database\Registry\Core folder
  2. restart the computer


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.