Cannot playback through Windows default audio device

Roon Core Machine

NAS QNAP TVS-463 Wired Ethernet - Intel Celeron CPU. 8GB RAM
Running latest version of Roon core.

Networking Gear & Setup Details

Roon player: Windows 10 laptop. Wifi
Roon core: QNAP TVS-463 Wired Ethernet
Network Switch: Netgear Nighthawk X6 R8000

Connected Audio Devices

Roon endpoints are Bluesound Node 2i, and Hegel P190. Both wired Ethernet through the Netgear Nighthawk. Everything works as expected through those endpoints. Recently I have the need to playback through Windows 10 laptop speakers or Windows 10 desktop speakers and that is the problem.

Number of Tracks in Library

Where do I look in Roon to see this? I’m guessing 5000 tracks. Roon says 889 albums.

Description of Issue

The goal is to have Roon play through my laptop speakers (and also my desktop speakers). I cannot get this to happen.
The problem occurs on my wifi connected Windows 10 laptop and on my Ethernet hard-wired connected Windows 10 desktop. The problem occurs when playing from Tidal, Qobuz, or local library.
I open Roon on the laptop and go to Settings > Audio and enable the Windows default device. Back in the browse screen, I select the playback device to be the laptop and then press play. No sound is played through the system. In fact, I can see the songs flashing past on the Now Playing bar. It just quickly goes through the playlist until it reaches the end then says “nothing playing”.
I’ve tried rebooting the OS, updating the OS, updating all audio drivers. Also, the problem occurs if I enable the Windows audio output device individually (Realtek WASAPI on the laptop, NVidia WASAPI on the desktop) and choose that as the playback device instead of the OS default audio out.
What am I doing wrong?

Have you added roon to the windows firewall?

Thanks for the suggestion. There are four “roon.exe” rules in the Windows firewall settings which I presume were created by the Roon installer. The rules allow all traffic inbound and outbound (all ports TCP and UDP) to the Roon executable. All the rules are enabled. I haven’t made any manual changes to the Windows firewall and I have it configured to alert me when it blocks a program.

As a test, I disabled the firewall, restarted, and the Roon problem still occurs. So my problem isn’t caused by the firewall.

1 Like

I had this happen last week on my Windows 11 laptop (the Core is another W11 laptop).
What I found is that if my Remote were connecting on WiFi, I needed to enable “Private” on my WiFi network connection in the Windows Settings Network menu. This enabled my Remote laptop to be discoverable by the Core laptop.

Not sure this is the case for you but it may be worth looking at your WiFi settings on the Remote laptop and ensuring it is in “Private” mode.

Thanks for the suggestion. All my devices are on the private network. The desktop is wired and also on the private network. Roon Player finds the Roon Core. Roon playback works on my 3 other Roon endpoints. So that isn’t the problem.

Out of curiosity, was your problem exactly like what I described where you can browse just fine but playback just silently zips through the playlist of songs on Tidal or Qobuz?

I don’t use any streaming services, I have about 17K tracks local. What I experienced was a sudden disapperance of any ability to play back locally on my Remote laptop. One last suggestion. Can you update the video driver on your laptop from the manufacturer’s (Intel, AMD, NVIDIA) website and not using the Windows Update feature?

Probably not the same issue, but I’ll tag @support for help.

The Roon playback problem occurs on two different PCs with very different hardware. So very unlikely it’s a driver issue. In any case, all drivers are current. I update the desktop PC drivers directly from NVidia. The laptop is a Certified Dell Precision so I won’t update that outside of Dells approved drivers.

Most likely I just have something in Roon configured incorrectly. This is first time I’ve needed to play back through the PC so I don’t know if this worked in the past. Perhaps I am expecting it to work in a way that it cannot?

Is your PC’s audio configuration set to Exclusive mode in Roon on the System Output or the other drivers available to you? Can you share a screenshot of your Audio options?

You also need to allow Raatserver

Normally I have Exclusive Mode set on the laptop but not set on the desktop. I’ve tried toggling the Exclusive Mode checkbox and restarting Roon. No difference. This is not a situation where Roon starts playing and I hear nothing. Roon never even starts playing anything. It just zips through the playlist flashing the song names.
What setting in the OS control panel could cause Roon to never start playing anything?

There are four “raatserver.exe” rules in the Windows firewall settings which I presume were created by the Roon installer. The rules allow all traffic public and private on all ports TCP and UDP. All the rules are enabled.

As I mentioned earlier, I disabled the firewall, restarted, and the Roon problem still occurs. So my problem isn’t caused by the firewall.

In Roon > Settings > Audio screen. I clicked the gear next to the PC default device and selected “device setup”. Then I clicked “Load Defaults” then Save. Playback on the default PC audio device worked fine after that without changing anything in Windows. This process worked on the desktop too. So clearly something got corrupted in the Roon settings at some point on both machines.
Thanks to everyone who tried to help.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.