Cannot remove old Roon backup folder from NAS

I am a fairly new Roon user. I have RoonServer installed on my QNAP NAS (connected by Ehternet to a Naim Uniti Nova—but that is irrelevant for the purposes of this post). I control Roon from my MacBook Pro and iPad and everything works perfectly.

However I foolishly originally set the Roon backup folder to be within the set of watched folders on the NAS. Having realised the error of my ways I set a new backup location on the NAS which works fine. The problem is that I can find no way of deleting the original backup location within the watched folders. I can delete original backups from within the folder (via Roon > Preferences > Backups > View Backups) but there seems to be no way of deleting the now redudant RoonBackups folder. The NAS merely revolts when I try (“Unknown error”) and Finder on the MacBook Pro is little more helpful (“The operation can’t be completed because you don’t have permission to access some of the items.”). Finder > Properties shows “custom access” for that folder.

Short of dynamite, does anyone have a useful suggestion? I have a tidy mind and this is untidy. :grinning:

@support can answer this for you.

@xxx many thanks for pinging. I didn’t like to do that in the hope of not troubling them!

1 Like

Don’t have any experience with watched folders on a NAS, but the simple-minded answer would be to ‘unwatch’ the folder, first? Is that a thing?

Does this make sense? Dunno…

Although the Roon lads will probably help you, I don’t think this is, technically, a Roon problem.

Oh, OK, I get why you don’t want to ping. :grin:

I’d have go at going to Settings, storage and unmount the NAS storage path that includes the old backup. Then try deleting.

Thanks for the very senisble ideas. Unfortunately if I go to Roon > Preferences > Storage and from there disable the watched folders I still can’t delete the rogue backup folder.

I rather suspect Roon does something about access to that folder which makes it hard to delete. I’ve tried displaying hidden files but didn’t really want to meddle further. I appreciate it’s merely a cosmetic issue but imagine there are others who from time to time need to be able to delete old Roon backup folders.

In any event, it’s not urgent and I do appreciate the contributions!

Hmm, you say ‘Disable’, but maybe you really meant ‘Remove’? That seems like what one would want to do.

Settings->Storage->(watched folder)->Remove

Probably just a typo.

I have tried “Remove” following your comment but I’m afraid that also led to the same result—an undeletable folder.

Let’s see what @support can contribute in due course.

1 Like

Hello @Stephen_C,

Thanks for contacting us regarding this issue. We don’t mind the pings when customers have actual support questions for us to answer :slight_smile: .

With that said, I would try to re-take the permissions for that folder through your OSX by using these instructions from Apple (except instead of the home folder, select the RoonBackups folder). I would set both read + write access for your logged in user for that folder and then try deleting it again.

Please let me know if that helps!


@noris thanks for the help and sorry for the slight delay responding. Unfortunately, having tried what you suggested I have to report that I’m getting the same error message.

This is what I did (just to show I followed what was suggested!) - having, for good measure, disabled the watched folders from Roon and made hidden files visible on the NAS:


and, as a result, when I tried to delete I received the same error message:


@Stephen_C - I would change the permissions for everyone to “Read & Write” and also click the cogwheel icon and press “Apply to enclosed items” as per the docs I sent. Please let me know if that helps.


@noris unfortunately macOS does not permit me to change the permissions on that folder for Everyone (even though I’m logged on to my MacBook Pro as administrator). I did “Apply to enclosed items” previously. Sorry for not making that clear.

@noris…success! I should have tried long ago logging on to the NAS as administrator and using the nuclear option. :grinning: The folder is gone - and I apologise for causing so much trouble.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.