Cannot start Roon client on Windows 10 desktop via remote desktop

This has been a problem all along. I still don’t understand why this won’t work. I have a reasonably decent Intel i7 desktop with GTX 1050 Ti. I mean it is not the most powerful video card, but how much power does Roon client really need?

If someone could explain, please.

It’s annoying to have to climb stairs up and down to get to this computer, because this is the computer connected to my DAC over USB cable. If I don’t start Roon on this computer, no other device can operate Roon on my OPPO ModWright 205 DAC.

Hi @G_Man,

It’s a limitation of Windows RDP and how it supports Open GL3.

Have you considered running Roon Server (ie Core only) rather than full Roon (Core & GUI) on this PC?

I had this problem and did a reasonable amount of research on it. I found two good detours, but no real solution.

The first is to use something like Teamviewer or VNC instead of Microsoft Remote Desktop Support to connect and start Roon. There’s a limitation in the MS implementation of RDP/RDS such that it won’t use the real display drivers on the remote and instead uses some basic MS display driver for video that doesn’t support OpenGL 3.0, so Roon Client croaks.

The second detour is to uninstall Roon on the remote system and install Roon Server instead. Set Roon Server to restart automatically after a reboot. You can then run Roon Client from wherever you please (phone, PC, etc.), tell it the Core is on your remote system, and the use the Client to control Roon.

Good luck.

Oh, thanks, guys, I really appreciate this! I’ll get VNC, that’s easy.

So that computer of mine is not the Roon server, it is just a Roon client. But, it is the one connecting to the OPPO. Until that client is running, I cannot see the OPPO zone on any of the other clients.

I run the server separately on a kickass 8750H gaming laptop that never goes to sleep:slight_smile:

Oh I see, do you ever use that PC for the Roon GUI? (I’m assuming you have other more accessible Roon clients). If not then consider just installing Roon Bridge on it, which will give you a Roon endpoint zone.

This for sure. If it is just functioning as an endpoint, no need for any other software on it.

Hi @G_Man,

The feedback you’ve received so far is spot on (thanks everyone :smile:). This is a limitation of Windows RDP and, based on your use case, it sounds like Roon Bridge would be a good idea.

You can read about RoonBridge here:

1 Like

Thanks for your help, gentlemen.

I still use that computer as Roon Client as well, so the Roon Bridge might not be the right solution. But VNC will definitely do it. Except there is some problem with the firewall and the VNC client is not talking with the VNC server. And when I turn off the firewall on both computers, I get a different error message saying the computer (presumably the server) is refusing the connection.

I need to work on this more.

You can actually have both on the same system. Load RoonBridge first, that way it can act as an endpoint without having to log into Roon. Then add Roon as a client, pointing to the server. Then when you are at the computer you can open up Roon and play music. And when not, you can just stream to it.

For example, I have a computer with a Dragonfly DAC connected to speakers. As long as the computer is on, I can use it as an endpoint with any other control device. If I am sitting at the computer, I can start the Roon program to run things.

What you don’t want to do is load RoonBridge and either RoonServer or Roon in a server capacity on the same system. But, RoonBridge and Roon (as client only) works for me.

You are right! I just did that and uninstalled VNC, and I am in business! These Roon people have really thought of everything. I didn’t even know RoonBridge existed.

And they should give you a free subscription for all the help you are giving to Roon users.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.