Cannot use eSATA on SynologyDS920+, have set drive description to RoonServer

First of all thanks to @crieke for his work on this. I have been able to get Roon working using a USB connected SSD drive and it runs really well.

I would like to use eSATA instead but I can’t get this to work. I’ve tried 2 different eSata cables/enclosures and followed the instructions I’ve found.

This screenshot shows I changed the description to RoonServer but roon throws an error whenever I run it and then works again if I go back to USB. The screenshot shows an old roonserver I setup internally 1st.

The name of the eSata share should be: RoonServer. Then it will work.

I will check it.
@Alfred_van_Hoorn: In general you are correct. eSata is an exception here, as the Synology Disk Station Manager unfortunately does not allow renaming eSata shares.

@crieke, you are right. That’s why I did not mentioned renaming. :smiley:

I have used a eSata connection to my SSD (with the Roon database on it) for several years without any problem.

Hi @crieke sorry to chase up but I’d really like to get the hard disk onto eSata to free up the USB slot at the rear.

Hi @Julian_Fricker,
I am really sorry, I got distracted with other things. I will check this on the weekend and let you know. I 'll receive a new esata adapter to test with until then.

Thank you and nothing to apologize for. I’m still using Roon on Synology thanks to your work.

@Julian_Fricker, maybe I can help you.

I have more than two years succesfully used a eSata port to connect my DS713+ to an SSD in combination with Roon Core on that same DiskStation.

Unfortunaltely it did not free up an USB port. I connected an SATA adapter on my SSD which end up with two cables: one to my DiskStation’s eSata port (for the data-exchange) and one to an DiskStation’s USB port (for power).

Thanks, I have another machine nearby that I’ll be using to get the USB power my eSATA cable needs.

So could you let me know how you configured your system to see the eSATA drive?
I’ve tried changing the description as shown in my screenshot, how is your setup different to that?

As far as I can remember you have to create a new shared folder on your satashare with the Name RoonServer. (I doesn’t work to change the satashare folder and give it the Description RoonServer).

Hi @Julian_Fricker,
i was able to test the database on an esata connected harddisk today.
After changing the description of the satashare to “RoonServer” (and renaming the old internal RoonServer shared folder), it was picked up and used by the Roon Server app.

As this does not seem to work on your Diskstation, I am wondering about the following details:

  • Which version of the Roon Server app is installed in the package center? (Is it the latest 2021-03-08?)

  • What filesystem is used on the esata drive? (exFat, ext4,NTFS, HFS…).
    This is how my drive is listed in the “External Devices” section of the DSM:

Have you tried to format the esatadrive on the diskstation? (!! Be aware, this will erase all data on the drive !!)

Kind regards
Chris