Can't access/reach Nucleus+ anymore


Since yesterday I can’t reach my Nucleus+ anymore. Neither my Roon app finds the device by any means nor does it show up in Fing app or iNet Scanner (IP Scanner).

Just before I was on vacation for a week, and updated (as I have done several timed before) the Ronn app plus the corresponding Nucleus+ flatware (firmware) – all without a problem. As I was able to use the device after that update for a day or two.

Now the device is “bricked” :-(.

In my world it would be easiest to simply clean install the device – but without being able to connect to it – i am lost…

I did find some thread on a hardware factory reset for the generic ROCK (Roon on Intel NUC) but I doubt that the procedure (especially the downloaded “generic” file) will work for my Nucleus.

Can anyone advice (or point me in the right direction) on how to get my Nucleus+ up and running again?

Best regards, Lorenz

Hi @Lorenz_Ismer,

Thanks for reaching out, and apologies for the trouble here.

Can you access the Nucleus Web Administration Interface?

Have you tried rebooting the device? Are the LEDs for the power button and Ethernet cable lighting up on the device?

Hi Dylan,
thanks for your quick reply.

Unfortunately NO – if I try “Settings – Setup – Configure Roon OS Devices” I get a spinning symbol only. As mentioned before – even an IP Scanner like Fing does not find the Nucleus+ on the IP that was used before (I always permanently link the DHCP address through my router (AFM FRITZ!Box 6590). Other than that neither the router find the Nucleus+ (although it finds any other device on my network) nor does Fing find its elsewhere with a new IP).

Best regards, Lorenz

For the sake of argument plug your Nucleus directly into the router, rather than through the network, power router down and on again and when up and running try the Roon web interface. Oh and maybe just use a spare Ethernet cable to rule that out.

Hi @Lorenz_Ismer,

Have you tried rebooting the device? Are the LEDs for the power button and Ethernet cable lighting up on the device?


Mark_Hyland’s tip actually got things up and running again. THANK YOU.

Connecting the Nucleus+ to the router directly (and unhooking all other cables) brought back the Nucleus+ to life :-). I did then reboot all other devices (like my 2 switches) – after all that the Nucleus+ was found by the Roon app again. Obviously it was (only) a network issue on my side.

Thank again for all your input!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.