Can't Add Album to Library in ARC

Tried to add a Tidal album to my library in ARC today. The toast prompt kept saying the album was added, but when I would refresh the album screen, it showed as not in my library (the add to library “plus” icon was present, not the favorite “heart”) and I couldn’t add tags to it.

Hi @JS_Gladstone,

Thank you for your patience while the tech support team worked through the queue to reach your report. If you’re still experiencing this problem, please let us know the name of the affected album so we can pinpoint the issue in diagnostics.

I recommend you also sign out/in of Tidal via Roon → Settings → Services to refresh your authorization.

We’ll keep an eye out for your response.

I have the same issue, works on desktop but arc is unable to add songs or albums and just resets status and shows the add button again. Tidal or Qobuz does not make a differerence.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.