Can't add my Synology Server [Solved]

@support Hi - I was hoping to resurface this issue. I’ve tried all your recommended guides and I can’t add my Synology NAS as a network share to my Roon Nucleus. I keep getting “unauthorized” error.

For context, I have connected via a wired ethernet connection from a Roon Nucleus (using the latest OS - using a Windows PC (with the latest a Windows 10 64-bit OS), and the latest Synology OS I am sure my username and password are correct since if I type it incorrectly, I get a wrong password message instead. I also have tried manually logging into the server with the same credentials. In the add network share dialog box, I using \\\Documents\Music. I also have a sonos and when I follow the same steps, it works.

I then tried moving my music from the Synology NAS to my main computer and got the same error. I then moved the music folder on sonos and it worked perfectly.

I appreciate any ideas or help. Thanks.

Hi Gary,
Sorry for the late reply. I have moved your post to the support section.
Does this issue still persist?
I was already testing a little bit and tried to replicate your scenario with my gear, but was so far not able to get that error (assuming your username and password are indeed correct).
Can you post a screenshot of your smb settings of your Synology. You can find these in the “Control Panel” -> “File Services”. Press the “Advanced” button in the SMB section there.
This is how it looks on my Diskstation:

Thanks for your follow up. My screenshot looks pretty similar:

Hello @Gary_Calega,

Sorry about the slight delay getting back to you here. First of all, I just want to confirm, are you using the newest 1.5 Core Update on your Nucleus? I would like to enable diagnostics on your account so our technical staff can get some more insight into what’s going on here. What this action will do is the next time the application is active on your core device a diagnostics report containing a set of your Roon logs will automatically be generated/uploaded directly to our servers. I would ask you to please reproduce the “unauthorized” error you are seeing and reply with the exact time that it occurs at so that we can cross-reference it in the logs we receive. I will be sure to update this thread once the report has been received so you know we have it and then we can proceed from there.


Might be worth checking that the Roon OS is similarly up to date on the web interface page of the nucleus.

Hi - Thanks for your help. Yes, I am running the newest 1.5 core and everything is stable. Happy to enable diagnostics - how do I do that?

Hello @Gary_Calega,

I can confirm that the mentioned diagnostics report has been received and is in our tech team’s queue for evaluation. Once the team has updated your ticket I will be sure to share their thoughts/findings with you in a timely manner. Your patience during this process is very appreciated!


1 Like

Hello @Gary_Calega,

Our tech team has been reviewing the received diagnostics report from your system and have asked if you could please verify that you are not using any special characters such as (äöü*+’#`´<>) in your login password for the Synology NAS? If you are, I would recommend changing your password and trying to login again and see if that works, otherwise please let me know when you have a chance and we can continue troubleshooting from there.



YOU SOLVED IT. Thank you so much. That was exactly the problem. I removed the special character from my password and now it works. Thank you!!!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.