Can't add NAS to library, wrong address?

Core Machine (Operating system/System info/Roon build number)

intel NUC8i7, win 10, Roon

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Router = fritzbox 7590, wireless to repeater, switch, NUC. NAS is attached to the router via USB, mediaserver function in the router is active.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

USB to miniDSP SHD

Description Of Issue

Whenever I try to add my network drive I get an error message: “an unexpected error has occured”.

I tried entering the following path, which worked for Bluesound’s Node 2:


The user credentials I log in with do have permission to enter that exact directory. When entering the address into the browser (chrome) on my PC I can access the NAS, but not from my tablet or phone, which I don’t understand either.
I also tried entering the IP instead of \… same result.

I listen to Tidal for 99%, yet I’d like to test that Roon-feature.

I’m a little lost. Any help is appreciated.

Perhaps your nas is on the fritz :wink:

but seriously I have never seen a NAS connect to a network via USB…are you sure this is how the NAS is meant to connect? You dont give any details of your NAS but if it has an Ethernet port I suggesting using it…not USB…if it only has USB then its not a NAS it’s a USB drive (perhaps with multiple disks in JBOD or RAID)

You also need to add the NAS as an SMB:// share

Hi @MBO,

I would double check to make sure that you don’t have any firewalls which could be blocking the connection to the NAS and that Fritzbox has SMBv1 turned on in the settings.

As @wizardofoz mentioned, NAS’ are typically connected over Ethernet and not USB, so this seems like some kind of configuration setting on the router itself.

One further thought, instead of using the hostname, you can try to use the IP address of the router or NAS itself with the SMB://share notation, that may help and more info regarding this aspect can be found in our Add Folders By Path Guide

It may not be a real NAS, it may just look like one but be a USB based Desktop Attached Storage.

Have you enabled SMB in Windows 10?

Installing the SMB1 protocol for Windows 10

Starting with Windows 10 version 1709, the network protocol SMB1 required for accessing storage (NAS) connected to the FRITZ!Box is no longer installed by default. Therefore, make sure that SMB1 support is installed on your Windows 10 computer:

  1. Click (Start) and then (Settings) in the Windows task bar.
  2. Click “Apps” in the “Settings” menu.
  3. Click “Programs and Features” in the “Related settings” section.
  4. Click “Turn Windows features on or off” in the “Uninstall or change a program” window.
  5. Enable the option “SMB 1.0/CIFS File Sharing Support” or “SMB1.0/CIFS File Sharing Support” in the window “Windows Features” and click “OK”.
  6. Click “OK”.
  7. Click “Restart now” to complete the installation procedure.

Or this might work better.

1 Like

What is the make and model number of the NAS that is plugged into the router? That would help give us insight into your setup.

This Fritzbox is a router that has a USB slot for a USB drive. Apparently it runs an OS (Fritz!OS) that makes the USB drive look like a network drive.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.