Can't connect after restoring Time Machine backup [Resolved]

The SSD crashed on my Mac Mini running Yosemite. I got the drive replaced and they did a fresh install of Sierra. I restored from Timemachine (data, not OS) and now I can’t connect to RoonServer. I’m running Roon on a separate Mac, which seems to see the Mac Mini core, but when I try to connect it just spins with the animated roon logo.

I’ve tried downloaded the latest version of RoonServer and Roon to no avail. I even tried installing Roon on the Mac Mini running RoonServer, but still no go. I’ve turned Firewall off on both Macs.

Hi @photon ---- Thank you for the report and sharing your feedback with us. Apologies for any confusion on my part, as I am in need of some clarification here.

Based on the screenshots you have shared below, when you’re selecting the Mac Mini running Roon server to be controlled by your other MAC (example #1) are you being prompted to log in again (example #2)?

Example #1

Example #2


No problem, I’ll clarify all the steps, since I omitted some. I believe this happened after I re-installed Roon on my non-core mac.

  1. Click on “Configure Roon OS devices on your network”
  2. Get stuck at this screen and manually abort:
  3. Click on Connect to the mac mini and get:
  4. Click Retry:
  5. Click Next:
  6. enter login details to Tidal:
  7. Click No Thanks:
  8. Click Update:
  9. Get Roon Login Screen and try to login, but it hangs:

Hi @photon ---- Thank you for the follow up and clarifying the steps you are taking here when trying to connect to RoonServer. Moving forward can you confirm if you restored your database from a Roon back up (i.e via dropbox)?


I had a Time Machine backup of the mac mini, from which I restored everything.

It’s been noted more than a few times that time machine is not going to work for backups of the roon databases.

There are built in options in roon to support multiple versions and locations for backups.

That’s good to know.

Now what can I do to fix this situation?

Hi @photon ----- Thank you for the follow up and verifying that information for me.

Unfortunately, if you don’t have a backup of the Roon database, that wasn’t created using Time Machine, you’ll need to start with a fresh database. You can do that by deleting the Roon database.


Thanks for your guidance. I’m still trying to get things working. I deleted the database, re-installed the latest version on the Mac Mini. On my Mac Laptop, I started Roon, saw the RoonServer on Mac Mini, went through the setup and got connected. I left to let the server ingest the files from my NAS into the library.

That was over a week ago and I finally decided to play some music. Unfortunately, I can no longer connect. I re-booted the Mac mini, but no change. I looked at the RoonServer logs and it looks like it’s doing stuff (like mounting the NAS, connecting to Tidal, …)

This is what I see on the Mac Laptop:

This is what I see on the Mac Mini if I start the Roon client:

On Mac Mini:
501 405 1 0 7:17PM ?? 0:06.86 /Applications/ --debug --gc=sgen --server RoonServer.exe
501 494 405 0 7:17PM ?? 1:27.38 /Applications/ --debug --gc=sgen --server RoonAppliance.exe
501 499 405 0 7:17PM ?? 0:00.00 /Applications/ 494
501 548 494 0 7:17PM ?? 0:05.53 /Applications/ --debug --gc=sgen --server RAATServer.exe

Hi @photon — Thank you for the feedback. Apologies for any confusion on my part, but may I kindly ask you to verify if you are running Roon Server + Roon remote on the Mac Mini? Based on your second screen shot that’s what appears to be going on, is that the configuration you want or are you just trying to run Roon server on that device?


The target configuration is to use the Roon Server only on the Mac Mini. I only installed Roon remote on there to try to eliminate the network as the source of the connectivity problems. I’m willing to start from scatch again if you tell me the best way to do the install. I’ve already lost my old library, so nothing to lose anymore.

Hi @photon ----- Thank you for the follow up and verifying the information for me. Here is what I would like you to do:

On the Mac Mini:

  • Locate your Roon Server folder according to these instructions. Being as you had Roon remote running on this device along side RoonServer, you will see a “Roon” folder in this directory as well.

  • Delete both the “RoonServer” and “Roon” folders.

  • Reinstall RoonServer from our website.

  • Once installed launch, RoonServer.

On the Mac Laptop:

  • Locate your Roon folder according to these instructions.

  • Delete the “Roon” folder.

  • Reinstall Roon remote from our website.

  • Once installed launch Roon remote and connect to RoonServer on the Mac Mini.

Please let me know how this completely new install goes and if you find yourself having connectivity issues again, in your follow up please provide the following:

  1. A description of your network configuration/topology as well as providing insight into any networking hardware that you may be implementing. I want to have a clear understanding of how your devices are communicating and what tools are being used to make those connections possible.


Thank you! I’m back in business. Now I just need to establish a backup strategy. I really think you guys should have a notification on initial installation/configuration that traditional backups won’t work with Roon. I’m pretty sad to have lost references to a lot of discovered music.

In fact for macs it might be worth explicitly exempting the roon folders from time machine backups.