Can't connect my Synology NAS

Core Machine (Operating system/System info/Roon build number)

Grimm MU-1 Server - Linux/RoonCore

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet connected from server to my Telstra Router and the same for my Synology

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Grimm Music Server
Description Of Issue

For the life of me, I have read so many posts but am finding it difficult trying to add my synology NAS to my server as a folder. I don’t have a problem locating the NAS on my laptops - Mac and Windows.

My NAS is called- DiskStation
My music folder is- Nevnas
my user name is- admin
and my password does not have any funny characters. Its just alpha numerical. And it is right as I can log into my Synology server on the web. I have activated the SMB and the advanced settings.

My host IP is-

I have tried all the below following combos in the ‘Network Share location’ with the below and all of them constantly give me an invalid path file message. As mentioned the user name and password of the disk station are correct.


This is driving me nuts, as I have spent several hours over two evenings. And hence I am turning to support for some guidance.

The new Grimm MU-1 server is sonically mind blowing and I want to now play my music from my Synology NAS.

Please help!


Below is a screen shot of my Synology settings.
I have also turned off all firewalls in the Synology momentarily.

I can’t believe the karma. It eventually worked.

smb:// was the path I had to place.

I could have sworn I did this yesterday too.

Well back to the music.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.