Can't connect Nucleus to Endpoint through NightHawk router

New to Roon, setting up Nucleus on network and it is working fine on this side of the router (Netgear Nighthawk RAX45), but my hi-end endpoint (Bricasti M3) located on the other side of the router is not seen.

I had a similar problem getting my 4k TV to connect to streaming services on the upstream side of this router. Neither Sony nor Netgear could identify and correct the problem. I had to run a dedicated line from the DSL modem bypassing the router.

I would do the same here except I have no more ports left on my modem. And beside that I am a little more than simply annoyed that this router is being a problem. Netgear did replace the router, but the new one behaves the same. Again, I am assuming the router is the problem, but I am pretty sure it is.

Not following the info on sides of the router. Could you provide a little more detail on your Network setup.

BTW, welcome to the community.

1 Like

Hello Mark, that sounds endlessly infuriating.
A few thoughts.

  1. take the router out back and put it out of your misery. Replace immediately.
  2. add a simple netgear switch to one port on your modem and it will give you more ports.

Roon is a lot of things, forgiving of network quirks is not one of them.

Yeah, I would like to sell this back to Netgear. Or jump up and down on it until it is nothing but powder. But I do need the Wi Fi it provides.

1 Like

A cheap netgear switch will give you the extra ports for a wired connection.
I recommend that path if you are unable to swap routers.

1 Like

“Upstream of the router” are ethernet devices (endpoints in this case) connected to the router by Cat 8 ethernet (along with Wi Fi connected devices). “Downstream of the router” is the DSL modem, which has four ports. The Nucleus is attached to one of these, as is the computer I am using at the moment. So between my Bricasti DAC and the modem (with the Nucleus attached to it) is the Netgear Nighthawk model RAX45 router.


Sorry if I seem a little testy. These kind of issues drive me nuts.

1 Like

I’m not real knowledgeable on Network setups. My modem is connected to the 8 port Router then everything else is connected to the router, Ethernet or Wi-FI. Have you tried Nucleus and endpoints connected to the router vs Nucleus connected to the modem and endpoint to the router?

No, they need to be in two physically different locations. I think I am going to buy a little dumb switch and use the dedicated TV line to it, then one drop to the TV and one to the Bricasti. I won’t be using both at the same time so that should be OK.

With a switch, you should be able use both at the same time.
If wanted. Wifi is far less forgiving than wired ethernet.

Make sure that everything is on the same subnet. Roon can’t see across subnets.


Does enabling Multicast on the router help with multiple subnets? Thought I read that on another post for similar issues.

I’m not a networking expert but I think the Nucleus and the endpoints must be connected to the same device. Your Nucleus is attached to the DSL modem and your Bricasti is connected to the Netgear router. I don’t think the router will be able to see the Nucleus. Does it show up as a connected device in the Netgear admin page?

1 Like

No, Roon cannot cross subnets, it all has to be in the same. I asked about subnets because using the nighthawk and the dsl, he could have a double Nat situation.

Hence the suggestion to check IPs to verify it was all one network subnet.

I read Cat8 cables, they can be very problematic, do you have any el cheapo cat5 or 6 cables to throw at it as a test?

1 Like

Problem solved. I bought a cheap 5 port unmanaged hub and fed it with the dedicated line I was feeding my TV with (direct from the DSL modem), then ran from there to both the TV and the Bricasti. Works a charm. So now the Nighthawk router is only handling Wi Fi, and no music. Though the iPhone, laptop, and iPad I control Roon with does connect via the Nighthawk.

FYI, all cat 8 cabling, including the phone line from the box outside the house directly to the modem. I like it because it is heavily shielded.

Thanks to all for the suggestions.


Well, not so fast. Yes, I am streaming via roon, that problem solved (sort of). But sound quality has taken a real hit. It sounds bloated, lacking in nuance, detail, and subtlety. A big step backward from streaming via my previous software (mconnect HD) and through my older network setup.

And unfortunately I can’t compare the two to verify that it is the network causing the problem because somehow roon is preventing the Bricasti from being seen by mconnect HD, so now I am locked into the roon environ? Not good, roon.

Maybe the wires settled, dunno, but sound is pretty glorious with good recordings today. I’m a happy camper. Thanks to all who helped.


Roon wont stop anything from being seen. This will be your network environment blocking it. It sounds like you may well have two networks running one from the DSL router and one on the Netgear. If the Netgear has the option switch it to bridge mode. Currently you have you ISP modem and Netgear handing out DHCP addresses you should only have one DHCP server on your network. Your WiFi one will have different subnet and UPnP will not cross subnets at all as your controlling it from a device on the WiFi. Roon as a controller can in some situations work over subnets it wholly depends on ithe network gear. It does in mine as I have purposely set separate networks to isolate my audio kit from my normal network. But this is all from one DHCP server and router and each network can talk to the other as I configure it so.

Your just in a better mood. Your state of mind has more of an influence on what your hear than any changes to your network will
ever cause.