Can't connect to Devialet Expert Pro 440

Roon Core Machine

Brand new iMac running MacOS Monerey

Networking Gear & Setup Details

Using Wifi hub from Sky

Connected Audio Devices

Wifi to Devialet 440

Number of Tracks in Library

None, just streaming

Description of Issue

Always worked fine, but the last few days got worse and worse. If I unplugged the Devialet and re-booted then ok but now even that does’t work.
When I set the Devialet to Roon Ready and try to play something, nothing plays. The Devialet flips to Air automatically and on my Mac it says ‘Audio Device in Use’.
Seems that I’ve got two versions of Devialet 440 in the devices set up.
One says via Devialet Air, the other says via Airplay.

I’m guessing the former gives better quality, but I think the two are interfering with each other maybe?

I’d like to just delete them out and re-install but the program won’t let me do that.

I tried deleting the core/app and reinstalling but when I reinstalled, it just came back with the original settings.

I’ve looked at the Devialet Air and Roon advice in the support but I’m not a techie and I frankly don’t understand it.

Help! This is WAY too complicated.

Thanks

Richard Anderson

Try to deactivate in the Devialet configurator all the inputs you do not use.
The same for connecting to the network: either Ethernet (this is preferable) or Wi-Fi.
If you are not using the Devialet driver installed in your Mac, then uninstall it (Roon does not need it).

Normally, in Roon you should also see a Devialet device with the RAAT protocol.

In my experience, Devialet AIR is the most stable. Roon RAAT is similar in terms of sound quality, but some Devialets have problems with Ethernet 1000 (Devialet bug).

Also, try to reboot everything: router, switches, Roon server and Devialet (unplug from wall socket, not using the remote only).

You can’t delete, but you can disable any you’re not using: Click the cog, select “disable”.

Screenshot 2023-01-01 at 19.26.33

Make sure your 440 (both units) is upgraded to Firmware-13.2.0.

Your 440 should appear 3 times in Audio settings: as RAAT, AIR, and Airplay devices. I’d recommend using the “Roon Ready” RAAT device in audio settings, though AIR works fine - Airplay should be avoided given the other two options. Disable the “devices” you’re not using to avoid confusion.

Depending on your setup, it might be worth running a network cable from your 440 to the router. I used wifi for ages, but a cable is honestly far more reliable. And a router and core reboot can work wonders!

Hey @Richard_Anderson,

Following up on this thread, I was able to take a look at your account and see that your Devialet was successfully linked to your core recently. Are you still running into connectivity issues?

If so, please write down the date and time the next time this issue pops up and share that info here. We’ll be able to take a closer look into what might be happening at the time of the disconnect.

@mikeb is correct here - hardwiring your setup would be an excellent next step in testing as well.

I’ll be on standby for your reply :+1: