Can't connect to ROCK after update

Core Machine (Operating system/System info/Roon build number)

NUC 7i5, ROCK Firmware build 186, Server Build 537, stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

wired Ethernet from Cisco switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Remote is iPad, Mac Pro desktop etc

Description Of Issue

Updated my remotes, but ROCK hadn’t updated. Reinstalled the firmware which brought the server up to build 186. Now can’t connect. I get the screen to connect with the info and green light but then when connecting just the bouncing ball and the intermittent waiting to connect message. Doesn’t matter which remote I’m trying from. Rebooted, restarted server etc etc. I have noticed if I leave it on the Choose Your Roon Core screen, it will occasionally flash to red (connection failed) and then back to green again. Tried it with two different switches. So something going on there. All other devices on the network working as they should.

In the past I’ve had this same issue for the last few updates, and had to reset the database and reinstall codecs etc. A real PITA to have to do this every time, and last time the backup failed so it was like starting from scratch again.

Before I go through all this again, will the backup restore work if it was from the previous build? Should I perhaps install Windows 10 and dump ROCK altogether and go with Core?

Hi Charles, just another friendly user trying to help out until support arrives.

Just changing a switch might introduce issues, especially if it is a managed switch. You mentioned Cisco, which model number is it. If it is a managed switch then you should take a look at that section under

Thanks. No that’s not it; the 2960 switches are cascaded and just tried #1 vs #2. Same behavior on both and both have been reset to factory default (unmanaged). Was working fine for months right up until I pressed that damn update button.

Ok, wanted to listen to music so went ahead and deleted the database, installed latest codecs, and restored from last night’s backup. Everything works now as it should. Would still like to know why this is necessary every time I do an update.

Hi @Charles_Peterson,

It’s hard to say exactly what happened without looking at logs (which won’t be possible right now since the database was deleted). If you see this happen again, please use the directions found here and send us over a set of logs using a shared Dropbox link.

With logs we should have a better idea of what might be happening, but if this is a recurring issue it’s possible that there might be failing hardware at play that is causing issues when Roon tries to update the database. I’d recommend doing checks on the drive where Roon is installed (and possible also the RAM) to make sure that there aren’t any issues.

Thanks Dylan. That’s something I’ll do. Roon was slowing down significantly for me pre-update (which I chalked up to heavy family internet usage due to the lockdown), so that might be a clue. Seems snappier now. Best, Charles

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.