Can't connect to ROCK

I can’t get my new ROCK as an option on the “Choose your Core” screen. After following setup instructions correctly (I think) I only have my “This Mac” as a selectable Core. I am able to see the ROCK on the it’s system status screen that confirms the “Operating System”, “Roon Database & Settings” and “Roon Server Software” are all Status “OK”.

I can also see the ROCK as “Networked These devices have been located on your network” on the “This Mac” core on the “Settings: Audio” screen.

I’ve tried the “Disconnect” from the “This Mac” core but it still comes up as the only option.

It’s probably something simple but I’m missing how to select the ROCK as a the core.

You have the IP address since you see the web UI.
Tell Roon you want to look for other cores and enter the iPad address.

Thank you. Yes I do have the IP address but I don’t know where to ask Roon to look for other cores. Where is that option?

@Scott_Figge Go to Settings -> General

Under general you will see your Current Roon Server. Disconnect from it and choose your new Roon Server.

Note: You probably don’t need to enter the new IP. Is all multicast so it should find it all by itself.

Yes, I have tired the disconnect. After Disconnecting, it goes to the “Choose Your Core” screen where the choices are “This Mac” only and no Rock option. There is an option at the bottom “Configure Roon OS devices on your network” which takes me to “Configure Roon OS” with Rock as the option with IP address and serial number. Selecting that takes me to the “Rock Core Kit” that confirms “Systems Status”, “Operating System” “Roon Database & Settings” and “Roon Server Software” all with"OK" status. There are options there to “Reinstall” the OS, “Reset” the DB and Settings and “Restart” Roon Server Software. I have not tried these but I’m tempted.

On that Select your core screen, there is something like Why can’t I see my core? (I don’t have it in front of me.) Click on that and you get to a field for the IP address.

Why wouldn’t it automatically find the core? Depends one the network. I believe that the automatic discovery protocol can’t jump across subnets, but if you give it the IP address Roon can operate ok across separate subnets. Possible explanation, I don’t know.

I tried this out of curiosity and making sure I have properly installed the software and it works great. It took about 10 minutes to complete but everything was restored to where it was.

In order to connect to ROCK, you don’t want to go to Configure Roon OS Devices. It’s already configured, you want to connect to it. Here:

My problem is I do not have that option on my screen. Only my Mac based core shows up. there is no “I want to connect to a different core” option on my screen…and no second icon of the Rock to select.

Has the previous core not been deauthorized? I do not recall the exact sequence in my transition to ROCK, but I did deauthorize the previous core via Roon Remote before I connected to ROCK.


I have no clue. Ask @support.

I got the option to make ROCK my new core during the config process. If you don’t say yes at that stage ROCK will simply come up as a potential network connected end point. If this is the case you have no database settings on ROCK so I don’t think you have anything to lose by hitting the reset. I would do so after a backup and de-authorising your old core. Then restore your backup to the new core.