Can't connect to Roon Nucleus

Networking Gear & Setup Details


Connected Audio Devices

Number of Tracks in Library

Description of Issue


I have been using a Roon Nucleus+ as my Roon Core for some time without difficulty or issues.

I recently tried to launch Roon on my iMac and now it says it cannot locate the Roon Core and I cannot also see the Nucleus in my external storage list of my iMac.

am not able to access the Web Administration Interface and have tried changing my ethernet cables, restarting the Nucleus but all have not been successful.

Please help.


Please help us to help you, and complete the template in detail. Thanks.

My Roon Nucleus is connected via Ethernet to an Asus router. The Nucleus has an internal storage hard drive which stores about 17000 songs in the library if memory serves. I play the Roon through Mytek Brooklyn Amp and DAC. The Roon Nucleus also serves as my core/server which i access through my iMac and also through another Matrix Audio DAC/Streamer.

I have not been able to connect to the Nucleus through any of these devices nor through my iPhone or iPad.


Insofar as it may be relevant, ethernet port on the Nucleus where i connect my ethernet cable is blinking green on one side but solid amber/yellow on the left side.


No Nucleus user here, but…
…the lights indicate Ethernet activity as well as it being a 100Mbit connection, so next step is to hook up a Monitor/TV to it to see messages that indicate boot status - maybe photograph what’s shown there on boot and share here…

As Roon’s knowledge base says…

Nucleus HDMI output displays a status screen that contains diagnostic info with IP address, build information, and server status.

1 Like

You might also try rebooting the router if you haven’t in a while. Do a full network restart, turn everything off, router/modem, pcs, macs, nucleus, etc. Then start at the modem/router turning everything on one at a time letting the devices fully start and get new IPs from the router.

Thanks, I tried that but still having the same problem. Not sure what to do anymore…

Can you look at the asus router admin page and see if there is a “clients” or connected devices table and see if the Nucleus shows up in there? Also check firewall settings and make sure nothing is blocking the nucleus or roon or the RAAT server

Thanks. I checked the router admin and could not see the Nucleus in the clients list. I recall seeing it before but is not there anymore despite the Nucleus being connected via ethernet to it. That also explains why it no longer appears on my iMac as an external device/server…
What else can i do? Thanks

I also tried this but all i see after connecting the Nucleus to a TV via HDMI is a black screen…

This sounds like a hardware failure to me. Is the Nucleus+ still under warranty? If so, you should return it to your dealer, or, if you bought it direct from Roon Labs, say that here, and the Support team will raise an RMA for you.

Thanks Geoff. I feared that that might be the likely cause. Unfortunately no longer under warranty…

OK, is most probably a failure of the M.2 SSD, which can be replaced. Hang tight, @support will be along after the weekend to advise you on the next steps.

Hi @Melvin_Sng ,

If there is no HDMI output, we may be dealing with a motherboard issue, unfortunately. Since the unit is out of warranty, you can try to perform a CMOS battery reset on the Nucleus, sometimes this has brought a few units back to life, I will PM you a link with instructions.

Since it looks like your Nucleus was an international sale, your other option would be for you to work with your dealer and then the dealer, in turn, to work with our local area distributor for evaluation of the unit and do an out-of-warranty repair for a fee. For more info on this aspect, you will want to discuss it with your dealer.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.